summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2023-09-20 11:31:34 +0200
committerlangurmonkey2023-09-20 11:31:34 +0200
commit6060d94d454488ef67b95e1b17f75c462c28a45c (patch)
treeda1291e61c5174fd216a9559e59b3d918003e392
parentbd6ee55f9bd72a6cf12714001531dc41ad711ad9 (diff)
downloadaur-6060d94d454488ef67b95e1b17f75c462c28a45c.tar.gz
Version 3.5.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--releasenotes.txt40
3 files changed, 15 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3f158902fe8..f80aa16c4e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.5.3.d076b1659
+ pkgver = 3.5.4.36b53b006
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.3.d076b1659/gaiasky-3.5.3.d076b1659.tar.gz
- md5sums = f65bd22c73edcdcff074cf22cf52a00f
- sha256sums = d01c472c88ae272dcaaff2abe0ad63727d6848a8b601f1fc2c935483d6dabd95
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.4.36b53b006/gaiasky-3.5.4.36b53b006.tar.gz
+ md5sums = c3050cfd5567cbc3c6b12656a2e748cd
+ sha256sums = 82934d209db08d9ecc5c652bf6fa96c220ad289b557e82de8ce26dedb8aee99e
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 62bf8af21925..7f9ce093a9c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.5.3.d076b1659
+pkgver=3.5.4.36b53b006
pkgrel=1
epoch=2
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("f65bd22c73edcdcff074cf22cf52a00f")
-sha256sums=("d01c472c88ae272dcaaff2abe0ad63727d6848a8b601f1fc2c935483d6dabd95")
+md5sums=("c3050cfd5567cbc3c6b12656a2e748cd")
+sha256sums=("82934d209db08d9ecc5c652bf6fa96c220ad289b557e82de8ce26dedb8aee99e")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index d8e9330d1a80..90438d01c3ed 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,34 +1,10 @@
-# Gaia Sky 3.5.3
+# Gaia Sky 3.5.4
## Features
-- use quaternion spherical linear interpolation for the camera orientation when exporting keyframes. The old setting 'camrecorder > keyframe > orientation' is not used anymore.
-- use quaternion interpolation for the camera transition methods in the scripting API implementation.
-- add direct playback capability to camera keyframe system.
-- keyframe system to use new camera path object in export operation.
-- add skip back/fwd, step back/fwd, play/pause buttons and timeline slider.
-- move keyframes logic and model to keyframe manager.
-- add tooltips to keyframe playback buttons.
-- add check for keyframe timings (t_kf * fps % 1 == 0) and respective notice.
-- add new visibility type 'Keyframes', which controls the keyframe points and lines. Add new keyboard mapping SHIFT+K to toggle it.
-- move `onlyBody` trajectory attribute to `bodyRepresentation`, which is an enum that enables the representation of only body, only orbit or both. The `onlyBody` attribute is still kept as a proxy. Rename `pointColor` to `bodyColor` in trajectories. `pointColor` is kept as an alias.
-- move from buffered file-backed recording and playback to model-backed solutions for the camrecorder. This means that, during recording, the data is captured and stored in memory and persisted to disk when the recording finishes. During playback, the data is loaded to memory at once at the beginning and played from there.
-- new welcome screen title design and splash.
-
-## Bug Fixes
-- mismatch in bundled JRE versions in install4j script. Fixes [#737](https://codeberg.org/gaiasky/gaiasky/issues/737).
-- clean editing keyframe on deletion. Fixes [#734](https://codeberg.org/gaiasky/gaiasky/issues/734).
-- check keyboard focus state when polling cursors in main mouse/kdb listener. Fixes [#733](https://codeberg.org/gaiasky/gaiasky/issues/733).
-- exit JVM process with a proper status code depending on application state.
-- glitches and artifacts in atmosphere ground tessellation shader.
-- base opacity applied to model bodies when rendered as billboards.
-- update minimum required JRE in install4j script to 15. Fix version tag.
-- use camrecorder target frame rate instead of frame output system one in keyframes.
-- raymarching event description.
-- small improvements in UCD parser for IDs and magnitudes.
-- do not preemptively check display resolution in macOS, as it usually runs a headless JVM.
-- do not render keyframe lines/points when camcorder is playing. Fix index issue in path linear interpolator. Fixes [#735](https://codeberg.org/gaiasky/gaiasky/issues/735).
-- atmosphere object distance falloff.
-
-## Merge Requests
-- Merge branch 'keyframes'
-
+- add square recursive grid style, additionally to the existing circular concentric rings.
+- add diagonal lines at 30 and 60 degrees to the circular recursive grid.
+- redesign time pane layout and widgets (warp slider, play/pause, information boxes, etc.) in controls window.
+- upgrade internal version numbering to include a sequence number within the revision (major.minor.revision-sequence). It should be backwards compatible, but starting with this version, internal version numbers have at least 7 digits instead of 5.
+- bump source version number.
+- refactor separator UI elements.
+- redesign loading screen to follow welcome screen style.