summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2019-01-11 12:44:56 +0100
committerlangurmonkey2019-01-11 12:44:56 +0100
commit661386582bd005e9715760b4808e953476f4f6cd (patch)
tree2347a946fc2439f0085a035babda89f57f58034a
parente385f1d439c1d35e44992a5f0f42da5f4dd6812b (diff)
downloadaur-661386582bd005e9715760b4808e953476f4f6cd.tar.gz
Version 2.1.7
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md78
-rw-r--r--PKGBUILD4
3 files changed, 58 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5741ff7edc13..ae1bada35ffe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 2.1.6.347344e1
+ pkgver = 2.1.7.439d4499
pkgrel = 1
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -9,8 +9,8 @@ pkgbase = gaiasky
license = MPL
depends = jre8-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.1.6.347344e1/gaiasky-2.1.6.347344e1.tar.gz
- md5sums = eda62e31b261845a15648bd9d9ea9985
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.1.7.439d4499/gaiasky-2.1.7.439d4499.tar.gz
+ md5sums = 31be8d91ae0ad12b4761b9c197988f25
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ca375ac020c8..ffba16a1a27c 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,8 +1,30 @@
<a name="unreleased"></a>
## [Unreleased](https://github.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.6...HEAD)
+[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.7...HEAD)
+<a name="2.1.7"></a>
+## [2.1.7](https://github.com/langurmonkey/gaiasky/tree/2.1.6) (2019-01-11)
+[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.6...2.1.7)
+
+### Bug Fixes
+
+- wait for tasks to finish before shutting down
+- about window layout in non-hidpi mode
+- 'data files not found' problem
+### Build system
+
+- remove run command echo, rearrange version logging
+- fix installer-img not found
+### Code Refactoring
+
+- topmost render method rewritten to avoid conditionals
+### Features
+
+- data download dialog details
+- improve music component with scrollable volume, track name and time position
+- add RUWE to octree generator
+
<a name="2.1.6"></a>
## [2.1.6](https://github.com/langurmonkey/gaiasky/tree/2.1.5) (2018-12-18)
[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.5...2.1.6)
@@ -16,7 +38,6 @@
- width of tabs in prefs window lo-dpi mode
- integer snapping in downl. mgr + part. effect
- add cubemap edge fix to particle group
-
### Build system
- update server datasets descriptor
@@ -26,20 +47,17 @@
- script to convert usual RA[HH:MM:SS] and DEC[deg:arcmin:arcsec] to degrees
- minify json descriptor files before pushing
- update data descriptor with new nbg catalog
-
### Code Refactoring
- variable name change: font3d -> fontDistanceField
- removed data and assets-bak folders from repository
- moved text utils methods and classes around
-
### Documentation
- remove confusing line
- environment variable to skip java version check
- update readme with some extra info on download manager
- extra documentation line in fxaa code
-
### Features
- catalog chooser widget rewritten to make it easier to understand
@@ -51,7 +69,6 @@
- add notice in catalog chooser
- star size affects particle groups
- update criteria to show catalog chooser
-
### Style
- nbg loader to manage distances better
@@ -63,24 +80,20 @@
### Bug Fixes
- null pointer when unloading stars [#322](https://github.com/langurmonkey/gaiasky/issues/322)
-
### Build system
- remove rpm deps as they depend on distro
- update build scripts to install4j 7.0.8
- update to libgdx 1.9.9
- update data with new dr2-verylarge catalog
-
### Code Refactoring
- regular textures to tex/base
- cleaned up logger situation
-
### Documentation
- update changelog
- update rpm install command [#317](https://github.com/langurmonkey/gaiasky/issues/317)
-
### Features
- LMC, SMC, datasets can require min gs version
@@ -90,7 +103,6 @@
- passive update notifier [#321](https://github.com/langurmonkey/gaiasky/issues/321)
- add download speed and progress in downloaded/total to download manager
- add progress MB data to downloader
-
### Style
- fix info message
@@ -110,11 +122,9 @@
- multiple scroll focus objects [#319](https://github.com/langurmonkey/gaiasky/issues/319)
- octree generator
- emission shader code
-
### Build system
- add xorg-xrandr as dep in aur pkg
-
### Features
- improve usability of download manager
@@ -125,7 +135,6 @@
- script to query HIP names in simbad
- add optional output folder to csv process
- script to process dr2 csv files
-
### Style
- wee reformatting
@@ -140,23 +149,19 @@
- minimap window
- accents and umlauts in user folder path (win) [#314](https://github.com/langurmonkey/gaiasky/issues/314)
- start button status update [#313](https://github.com/langurmonkey/gaiasky/issues/313)
-
### Code Refactoring
- startup log
- shader include directive changed
-
### Documentation
- remove old references to `gaiasandbox`
-
### Features
- new shader init & various improvements
- add proper motions to stil data provider
- initial support for proper motions over SAMP
- individual constellation selectors [#275](https://github.com/langurmonkey/gaiasky/issues/275)
-
### Style
- GaiaSky.java to use LF instead of CRLF
@@ -173,35 +178,60 @@
- heap sizes in build script
- macOS -XstartOnFirstThread flag
- macos builds tweaks
+- heap sizes in build script
+- macOS -XstartOnFirstThread flag
+- assets location in install4j template
+- macos builds tweaks
+- heap sizes in build script
+- macOS -XstartOnFirstThread flag
+- macos builds tweaks
+- macos builds tweaks
+- heap sizes in build scripts
+- heap sizes in build script
+- macOS -XstartOnFirstThread flag
+- macOS -XstartOnFirstThread flag
- global key bindings affect invisible GUIs [#311](https://github.com/langurmonkey/gaiasky/issues/311)
- fix `p` double-mapping [#310](https://github.com/langurmonkey/gaiasky/issues/310)
-
### Build system
- installer detects and removes previous versions
- new gradle 5 compile dep format
- update to lwjgl 3.2.3
+- update to lwjgl 3.2.3
- missing flag in rund, fix caps in ruler
- new gradle 5 compile dep format
+- update to lwjgl 3.2.3
+- update to lwjgl 3.2.3
+- new gradle 5 compile dep format
+- update to lwjgl 3.2.3
+- new gradle 5 compile dep format
+- update to lwjgl 3.2.3
+- update to lwjgl 3.2.3
- add javadoc generator and publisher
-
### Code Refactoring
- bin to scripts, now settled
- scripts moved to bin, bin in git
-
### Documentation
- small tweak to changelog template
- improve git-chglog configuration
- update changelog
-
### Features
- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
- cosmic ruler [#296](https://github.com/langurmonkey/gaiasky/issues/296)
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
- API calls to disable and enable the GUI [#312](https://github.com/langurmonkey/gaiasky/issues/312)
-
### Style
- fix issues with merge to bring it back to a working state
@@ -218,7 +248,6 @@
- fix for windows paths [#309](https://github.com/langurmonkey/gaiasky/issues/309)
- fix run script and play camera windows
- update changelog
-
### Features
- add quit confirmation dialog
@@ -232,7 +261,6 @@
- crash if no internet connection present [#308](https://github.com/langurmonkey/gaiasky/issues/308)
- fix description of very large catalog
-
### Documentation
- update changelog
diff --git a/PKGBUILD b/PKGBUILD
index 680394cfb467..487aefd34c0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=2.1.6.347344e1
+pkgver=2.1.7.439d4499
pkgrel=1
epoch=
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -22,7 +22,7 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/$pkgver/$pkgname-$pkgver.tar.gz")
noextract=()
-md5sums=("eda62e31b261845a15648bd9d9ea9985")
+md5sums=("31be8d91ae0ad12b4761b9c197988f25")
validpgpkeys=()
prepare() {