summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2018-12-03 14:26:01 +0100
committerlangurmonkey2018-12-03 14:26:01 +0100
commit6b0b9b64d724c2692eb43ce51a6f695d9cec19a2 (patch)
tree4b27afaefa486581d3c03ce7be78dd53780b6c49
parentabda6484b5561277bda52df059f5c226e395f14f (diff)
downloadaur-6b0b9b64d724c2692eb43ce51a6f695d9cec19a2.tar.gz
Version 2.1.5
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md73
-rw-r--r--PKGBUILD4
3 files changed, 76 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 081a671387af..dde76aa582b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 2.1.4.8aba48da
+ pkgver = 2.1.5.9bd34a65
pkgrel = 1
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -9,8 +9,8 @@ pkgbase = gaiasky
license = MPL
depends = jre8-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.1.4.8aba48da/gaiasky-2.1.4.8aba48da.tar.gz
- md5sums = 4cba6a7dacb94f2fe53c4652c0d4b956
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.1.5.9bd34a65/gaiasky-2.1.5.9bd34a65.tar.gz
+ md5sums = 5e85ad624ee69dcd054fe96f706619e2
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c548472d764e..4f2ab5ac3f91 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,14 +1,49 @@
<a name="unreleased"></a>
## [Unreleased](https://github.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.4...HEAD)
+[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.5...HEAD)
+<a name="2.1.5"></a>
+## [2.1.5](https://github.com/langurmonkey/gaiasky/tree/2.1.4) (2018-12-03)
+[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.4...2.1.5)
+
+### Bug Fixes
+
+- null pointer when unloading stars [#322](https://github.com/langurmonkey/gaiasky/issues/322)
+### Build system
+
+- remove rpm deps as they depend on distro
+- update build scripts to install4j 7.0.8
+- update to libgdx 1.9.9
+- update data with new dr2-verylarge catalog
+### Code Refactoring
+
+- regular textures to tex/base
+- cleaned up logger situation
+### Documentation
+
+- update changelog
+- update rpm install command [#317](https://github.com/langurmonkey/gaiasky/issues/317)
+### Features
+
+- LMC, SMC, datasets can require min gs version
+- add support for nebulae
+- non-jsonloader autoload files
+- billboard galaxies
+- passive update notifier [#321](https://github.com/langurmonkey/gaiasky/issues/321)
+- add download speed and progress in downloaded/total to download manager
+- add progress MB data to downloader
+### Style
+
+- fix info message
+
<a name="2.1.4"></a>
-## [2.1.4](https://github.com/langurmonkey/gaiasky/tree/2.1.3) (2018-11-22)
+## [2.1.4](https://github.com/langurmonkey/gaiasky/tree/2.1.3) (2018-11-23)
[Full changelog](https://github.com/langurmonkey/gaiasky/compare/2.1.3...2.1.4)
### Bug Fixes
+- locale index overflow
- german translation and locale initialisation [#320](https://github.com/langurmonkey/gaiasky/issues/320)
- do not preselect default dataset, only base data
- sizing of download manager window
@@ -30,6 +65,9 @@
- script to query HIP names in simbad
- add optional output folder to csv process
- script to process dr2 csv files
+### Style
+
+- wee reformatting
<a name="2.1.3"></a>
## [2.1.3](https://github.com/langurmonkey/gaiasky/tree/2.1.2-vr) (2018-10-31)
@@ -70,6 +108,18 @@
- heap sizes in build script
- macOS -XstartOnFirstThread flag
- macos builds tweaks
+- heap sizes in build script
+- macOS -XstartOnFirstThread flag
+- assets location in install4j template
+- macos builds tweaks
+- heap sizes in build script
+- macOS -XstartOnFirstThread flag
+- macos builds tweaks
+- macos builds tweaks
+- heap sizes in build scripts
+- heap sizes in build script
+- macOS -XstartOnFirstThread flag
+- macOS -XstartOnFirstThread flag
- global key bindings affect invisible GUIs [#311](https://github.com/langurmonkey/gaiasky/issues/311)
- fix `p` double-mapping [#310](https://github.com/langurmonkey/gaiasky/issues/310)
### Build system
@@ -77,7 +127,16 @@
- installer detects and removes previous versions
- new gradle 5 compile dep format
- update to lwjgl 3.2.3
+- update to lwjgl 3.2.3
- missing flag in rund, fix caps in ruler
+- new gradle 5 compile dep format
+- update to lwjgl 3.2.3
+- update to lwjgl 3.2.3
+- new gradle 5 compile dep format
+- update to lwjgl 3.2.3
+- new gradle 5 compile dep format
+- update to lwjgl 3.2.3
+- update to lwjgl 3.2.3
- add javadoc generator and publisher
### Code Refactoring
@@ -91,7 +150,17 @@
### Features
- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
- cosmic ruler [#296](https://github.com/langurmonkey/gaiasky/issues/296)
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
+- update to lwjgl3 backend
- API calls to disable and enable the GUI [#312](https://github.com/langurmonkey/gaiasky/issues/312)
### Style
diff --git a/PKGBUILD b/PKGBUILD
index 07bf09343194..48167a017422 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=2.1.4.8aba48da
+pkgver=2.1.5.9bd34a65
pkgrel=1
epoch=
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -22,7 +22,7 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/$pkgver/$pkgname-$pkgver.tar.gz")
noextract=()
-md5sums=("4cba6a7dacb94f2fe53c4652c0d4b956")
+md5sums=("5e85ad624ee69dcd054fe96f706619e2")
validpgpkeys=()
prepare() {