summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2024-01-26 10:24:45 +0100
committerlangurmonkey2024-01-26 10:24:45 +0100
commit701e48d4c282d831f0163ebb6823220bf90d4408 (patch)
treeaa1c9c9225b7fe561e678e8953b49d129d4dff4b
parentb3669da8ee78b6c5cc1b94f17780e89e5a8b2e4f (diff)
downloadaur-701e48d4c282d831f0163ebb6823220bf90d4408.tar.gz
Version 3.5.8.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--releasenotes.txt53
3 files changed, 55 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2805962ca00..347cdfb268e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.5.7
- pkgrel = 3
+ pkgver = 3.5.8
+ pkgrel = 1
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.7-3.8be0b0add/gaiasky-3.5.7-3.8be0b0add.tar.gz
- md5sums = 4d04dc90728f3bbc020d989213f7c123
- sha256sums = 5ffc2dfd3660ad77a8d3d10f8836e146cbf08bce4cdbc6612a8ee8870e6186e1
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.8.530711afe/gaiasky-3.5.8.530711afe.tar.gz
+ md5sums = 5995f291500ce24ea61983c435a72a22
+ sha256sums = 51b6774d1f8c12b6f0c604e35cd621d9352554f10446cec9bf248197c90e2416
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 7702c69afb5a..a9687411880a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.5.7
-pkgrel=3
+pkgver=3.5.8
+pkgrel=1
epoch=3
-versionstr=3.5.7-3.8be0b0add
+versionstr=3.5.8.530711afe
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("4d04dc90728f3bbc020d989213f7c123")
-sha256sums=("5ffc2dfd3660ad77a8d3d10f8836e146cbf08bce4cdbc6612a8ee8870e6186e1")
+md5sums=("5995f291500ce24ea61983c435a72a22")
+sha256sums=("51b6774d1f8c12b6f0c604e35cd621d9352554f10446cec9bf248197c90e2416")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 5c492072e1b6..5709581821aa 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,10 +1,47 @@
-# Gaia Sky 3.5.7-3
+# Gaia Sky 3.5.8
+
+## Features
+- add bookmarks section in gamepad GUI. See [#757](https://codeberg.org/gaiasky/gaiasky/issues/757).
+- cloud shadow projections on the surface of planets, for regular textures, cubemaps and SVT clouds.
+- add new `backupSettings()` and `restoreSettings()` API calls to back up and restore the entire settings in Gaia Sky from a script.
+- move 'star glow over objects' check box to Scene settings > Stars section.
+- add used, free, allocated and total memory to memory information window in help dialog.
+- enable eclipse outlines (for umbra and penumbra) by default in configuration file.
+- add application-level shader disk cache that stores binary shaders to disk to speed up application startup. Disabled by default, as most GPU drivers already do this on their own.
+- add binary particle group loader/writer to be able to load particles using an own binary format that loads much faster.
+- support `PARTICLE_EXT` attributes, additionally to the base `PARTICLE` attributes in the new binary format for particle groups.
+- increase number of divisions in shapes around objects from 15 to 35. Do not cull faces. See [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
+- enable exporting cubemap sides to image files, action bound to `F7` by default. Fixes [#753](https://codeberg.org/gaiasky/gaiasky/issues/753).
+- adjust constants so that the Sun size is accurate.
## Bug Fixes
-- columns corresponding to the same UCD maintain the order of appearance in the source table when used.
-- use concurrent hash set in 'selecting' list in the OpenXR input listener to prevent concurrent modification errors.
-- resizing log window does not resize contents. Fixes [#749](https://codeberg.org/gaiasky/gaiasky/issues/749).
-- prevent getting name from second closest object if it is invalid. Fixes [#750](https://codeberg.org/gaiasky/gaiasky/issues/750).
-- use logical keys instead of key codes by converting GDX's codes to GLFW, which uses the logical keyboard layout. Fixes [#748](https://codeberg.org/gaiasky/gaiasky/issues/748).
-- rename makefile, update build script to detect `/opt/gaiasky` installation.
-- use default mappings file if the configured one does not exist.
+- use actual tree map for currently pressed keys in keyboard input controller, so that actions can be retrieved reliably.
+- do not activate surface mode (where the view follows the mouse location) with gamepad input.
+- layout and information in about/help dialog.
+- dataset detection to use dataset key by default instead of name.
+- apply graphics quality after restart. Remove graphics quality update events.
+- graphics quality update is now a 'needs restart' operation, otherwise the system crashes trying to load in new parameters, textures and so on. This is part of [#719](https://codeberg.org/gaiasky/gaiasky/issues/719).
+- increase constellation and boundaries line width to prevent rastering artifacts. This is part of [#719](https://codeberg.org/gaiasky/gaiasky/issues/719).
+- star flickering issues due to quad sizes mended by setting a minimum quad solid angle roughly equal to the pixel size of the back-buffer. Fixes [#719](https://codeberg.org/gaiasky/gaiasky/issues/719).
+- tooltips in number validators using the `MAX_VALUE` or `MIN_VALUE` should use infinity instead. Part of [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
+- add orientation to shape dialog (camera, equatorial, ecliptic, galactic). Fixes [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
+- remove all shapes [& around object] actually removes all shapes and not only the first in the list. This is part of [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
+- default to scientific notation only when abs(num) > 9999. Fixes [#755](https://codeberg.org/gaiasky/gaiasky/issues/755).
+- possible null pointer exceptions in OpenXR driver.
+- enable breaking string sequences at forward and backward slashes, as well as whitespaces. This prevents overflown content in the error dialog in certain cases.
+- run actual octant update code in the main thread.
+- particle sizing and size limits in the loader.
+
+## Performance Improvements
+- remove unnecessary synchronized blocks from index.
+- use parallel sort instead of regular single-threaded sort for particle and star sets.
+- make sure that unseen stars (i.e. computed final color is 0) do not take up fragment shader resources.
+
+## Code Refactoring
+- rename attributes of UCD and UCDParser to comport with the global style.
+
+## Build System
+- upgrade to gradle 8.5.
+
+## Merge Requests
+- Merge branch 'star-shading'