summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2024-03-14 09:00:05 +0100
committerlangurmonkey2024-03-14 09:00:05 +0100
commit89cfd047f722fe1199c89a46ffc58c9bf5f661c0 (patch)
tree19b85ad9005ee16860958809bc167a9d29802e8f
parent08dd6ca935dc11af6d9976913a32dbb32992fbe4 (diff)
downloadaur-89cfd047f722fe1199c89a46ffc58c9bf5f661c0.tar.gz
Version 3.6.0-2.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--releasenotes.txt32
3 files changed, 16 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48eeeed1166d..9c31a460b2c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
pkgver = 3.6.0
- pkgrel = 1
+ pkgrel = 2
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.6.0.afdd9547d/gaiasky-3.6.0.afdd9547d.tar.gz
- md5sums = 43c86508a144c2250fb2a4e63435a1a3
- sha256sums = db4029a782ac3c2e25eb4c54913a9f6753c2495c35c9dd08d900c4b7abf0249c
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.6.0-2.4479175dc/gaiasky-3.6.0-2.4479175dc.tar.gz
+ md5sums = 7c0fdf82f1506752e1fdf3e0f40af4ea
+ sha256sums = 3f4ff357530a9bbf5cc6689fea379f6048843ec8b8edd7f89c47bc51a2ed2317
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 0ea1a5bce6ac..596e74ef2849 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
pkgver=3.6.0
-pkgrel=1
+pkgrel=2
epoch=3
-versionstr=3.6.0.afdd9547d
+versionstr=3.6.0-2.4479175dc
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("43c86508a144c2250fb2a4e63435a1a3")
-sha256sums=("db4029a782ac3c2e25eb4c54913a9f6753c2495c35c9dd08d900c4b7abf0249c")
+md5sums=("7c0fdf82f1506752e1fdf3e0f40af4ea")
+sha256sums=("3f4ff357530a9bbf5cc6689fea379f6048843ec8b8edd7f89c47bc51a2ed2317")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index f46f27f706f1..1bd67d26acfd 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,28 +1,12 @@
-# Gaia Sky 3.6.0
+# Gaia Sky 3.6.0-2
## Features
-- add support for OptFlowCam (Piotrowski 2024) method to convert keyframes into camera path files. Gaia Sky calls the local python3 interpreter to process the keyframe files, so a local python3 installation (with numpy) needs to be in place for it to work.
-- add support for B-splines, additionally to Catmull-Rom splines, as a method for interpolating positions between keyframes.
-- reorganize keyframes window layout for better use of space.
-- add different durations for the transitions in position and orientation in the API call.
-- add smooth interpolation methods to `cameraTransition()` calls. The new methods can use either a logistic sigmoid or a logit function. Smoothing factor is configurable via a parameter.
-- add 'textureAttribute' to particle sets, so that textures are selected with respect to the value of an attribute.
-- use local dataset descriptors to construct catalog infos, when they are not explicitly set.
-- enable local data information in the '+ info' window. This displays the local data on an object. In particle and star groups, the extra attributes are also offered.
-- enable extra arguments of type string for star and particle sets.
-- rename 'star systems' group to 'exoplanets \& extrasolar systems'. Add icons to group title in dataset manager.
-- add support for multiple key sets bound to actions in hotkey tooltip.
-- keyframes and camera path file saving no longer overwrites existing files. Instead, it generates a new unique file name based on the given one.
-- support comma- as well as whitespace-separated values for camera and keyframes files. Default to comma-separated values for writing.
-- add API call to get the window coordinates of an object, in pixels.
-- add API calls to do camera transitions only in position and orientation.
-- add time transition API call and test script.
+- annotate camera files with frame rate so that playback can adjust it automatically.
## Bug Fixes
-- check leap years in date dialog.
-- prevent NaNs in some camera operations.
-- clean up test scripts a bit.
-- `startRecordingCameraPath(String filename)` does not use the filename correctly.
-
-## Build System
-- update dependency library versions.
+- camcorder play and record button inconsistent states.
+- state handling in the camcorder.
+- `sleep(seconds)` call also respects the camcorder FPS setting during recording.
+- rename some API calls, deprecate old versions.
+- add companion calls for camera orientation and position transitions.
+- orbit coordinate not working when time is before the orbit start.