summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2019-10-31 11:00:51 +0100
committerlangurmonkey2019-10-31 11:00:51 +0100
commita870507420248112896a9417d3f0e01b253e4a93 (patch)
tree945e5a9bed37d4c4421bbdce9ddd60f3c064e8ab
parent3002d19cb76062c2249dfbb80f77077003982610 (diff)
downloadaur-a870507420248112896a9417d3f0e01b253e4a93.tar.gz
Version 2.2.2
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md79
-rw-r--r--PKGBUILD4
3 files changed, 84 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 158cc0d457ac..5d23b86532ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 2.2.1.90d5543a
+ pkgver = 2.2.2.084a01b2e
pkgrel = 1
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -9,8 +9,8 @@ pkgbase = gaiasky
license = MPL
depends = jre11-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.2.1.90d5543a/gaiasky-2.2.1.90d5543a.tar.gz
- md5sums = f04bceec2f3550a62cd26553763d358f
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.2.2.084a01b2e/gaiasky-2.2.2.084a01b2e.tar.gz
+ md5sums = 99ac1ed7c5b8c4d921b4eb8c38b9e35c
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 3a945628eca5..1ca1b1fe5c94 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,9 +1,88 @@
+<a name="unreleased"></a>
+## [Unreleased](https://gitlab.com/langurmonkey/gaiasky/tree/master)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.2...HEAD)
+
+
+<a name="2.2.2"></a>
+## [2.2.2](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.1) (2019-10-31)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.1...2.2.2)
+
+### Bug Fixes
+
+- crash loading scene graph on windows [#306](https://gitlab.com/langurmonkey/gaiasky/issues/306)
+- add default controller rendermodel in case no suitable model is found
+- controller identifier in SteamVR - controllers work again when using SteamVR
+- block motion blur if vr mode is on
+- STIL catalogs not scaling well with global scale factor
+- catalogs loading twice
+- catalog info creation from json
+- wrong frame size when UI elements are on in VR
+- graphics quality images not found looking to lower qualities - not it also looks for the image in higher qualities
+- star group label scale and size
+- live update of number of glow lights
+- scripting crash when running several successive scripts
+- eq/ec/galtoInternalCartesian() calls unit fix
+- scripts using 'Sol' instead of 'Sun'
+- adjust star brightness map to magnitudes
+- enable input after script is finished, log connection details
+- layout of datasets pane
+- billboard positioning
+- orientation lock for quaternion-based objects
+- dataset color cycling
+- closest body being null in first frame [#303](https://gitlab.com/langurmonkey/gaiasky/issues/303)
+- crash resizing window when loading scene graph
+- add screen size check before persist
+- java version string without minor or revision [#302](https://gitlab.com/langurmonkey/gaiasky/issues/302)
+### Build System
+
+- improve crash reporting by also outputting the log
+- update source version number to 020202
+- update to gdx 1.9.10, gradle 5.6.2
+### Code Refactoring
+
+- motion blur shaders to work like the rest
+- complete package renaming
+- package rename, first commit
+- relocate some functions to more suitable spots
+### Documentation
+
+- info on vr controls and whatnot
+- clarify OpenComposite vs SteamVR for running with Oculus headsets
+### Features
+
+- minimaps finished with local group (1 and 2) and High-z
+- container background to notifications interface
+- better milky way in high and ultra quality
+- use texture_array for milky way components
+- scaling milky way particles
+- add dataset visibility toggle to context menu
+- add minimap scales for inner/outer solar system, heliosphere, oort cloud
+- add axes objects and show map button
+- improve context menu, add highlight and quit actions
+- add twitter info and fix help layout
+- add paths to help dialog (config, data, screenshots, frames, music, mappings)
+- add ecliptic and galactic longitudes and latitudes to filter attributes
+- add collapse/expand button to debug interface
+- user-defined per-dataset filters
+- add epicycles script plus some handy API calls
+- add brightness power to config file
+- add particle groups as catalog infos, start filters
+- add CPU detection to system information
+- add setCenterFocus() API call to disable focus centering
+- add API calls to get unit conversion factor
+- color picker to highlight datasets
+- colormap stars according to arbitrary attributtes (first draft)
+- add new default colors
+- update post-processing effects in real time when changing graphics quality
+- new velocity-based camera blur
+
<a name="2.2.1"></a>
## [2.2.1](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.0) (2019-09-10)
[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.0...2.2.1)
### Bug Fixes
+- spacecraft mode broken
- moon coordinates typo causing high-frequency sinusoidal drift
- greedy texture initialization works again
- init vr models after vr context creation
diff --git a/PKGBUILD b/PKGBUILD
index 5586289e9620..dd6700478231 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=2.2.1.90d5543a
+pkgver=2.2.2.084a01b2e
pkgrel=1
epoch=
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -22,7 +22,7 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/$pkgver/$pkgname-$pkgver.tar.gz")
noextract=()
-md5sums=("f04bceec2f3550a62cd26553763d358f")
+md5sums=("99ac1ed7c5b8c4d921b4eb8c38b9e35c")
validpgpkeys=()
prepare() {