summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2023-03-09 08:44:44 +0100
committerlangurmonkey2023-03-09 08:44:44 +0100
commitac8ca68377d589c5302d78f5e6375494a37cecfe (patch)
tree3d90fc249e6633bf3f8e7182db599a488aa590d6
parentd41b482f667dee58b0691fe3fc5ee55ee71563c3 (diff)
downloadaur-ac8ca68377d589c5302d78f5e6375494a37cecfe.tar.gz
Version 3.4.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--releasenotes.txt54
3 files changed, 37 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08e27aa827f7..433eb5d74fc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.4.0.33ecc89f4
+ pkgver = 3.4.1.0cf299d94
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.4.0.33ecc89f4/gaiasky-3.4.0.33ecc89f4.tar.gz
- md5sums = 133a92778af93027b2da8a36c778d66a
- sha256sums = 3000267734d51835dd57101638950c03cff3a02d0ba6bec027ef1d2370142c58
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.4.1.0cf299d94/gaiasky-3.4.1.0cf299d94.tar.gz
+ md5sums = 121ad79ca7bbfc315377b74902121120
+ sha256sums = d3d1444e8cceec89f307ee59ebd9621113666cf8f08cdeebda456f85aa776148
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index e2697a5a9648..90286fb0130d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.4.0.33ecc89f4
+pkgver=3.4.1.0cf299d94
pkgrel=1
epoch=2
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("133a92778af93027b2da8a36c778d66a")
-sha256sums=("3000267734d51835dd57101638950c03cff3a02d0ba6bec027ef1d2370142c58")
+md5sums=("121ad79ca7bbfc315377b74902121120")
+sha256sums=("d3d1444e8cceec89f307ee59ebd9621113666cf8f08cdeebda456f85aa776148")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index a7ff13989947..27f89791185b 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,32 +1,38 @@
-# Gaia Sky 3.4.0
+# Gaia Sky 3.4.1
## Features
-- sparse virtual texture support. This unlocks new virtual texture (VT) datasets, where extremely large textures are split in tiles and loaded and streamed to the GPU on-demand.
-- add filter box to dataset lists in the dataset manager.
-- add 'clear' button to text fields to clear the contents at once.
-- add initial support for the JPEG-XL (.jxl) image format.
-- enable updating pre-loaded objects via JSON, add SVT (sparse virtual textures) component and loading mechanisms.
-
-## Build System
-
-- upgrade build script to install4j 10.0.4.
-
-## Documentation
-
-- flag Gaia Sky VR as alpha software.
+- initial implementation of a proper in-scene VR user interface with mouse interaction.
+- use gamepad UI in VR.
+- VR controllers use same mappings format as gamepads.
+- add specific mappings for Valve Index VR controllers.
+- add generic VR controller model.
+- welcome and loading VR screens are now 3D surfaces in-scene.
+- add VR controller interaction in VR welcome screen.
+- sRGB setting enables SRGB format only in VR frame buffers.
## Bug Fixes
-- VR controller paths in VR context. Fixes [#702](https://codeberg.org/gaiasky/gaiasky/issues/702).
-- build task including certs and other unneeded stuff.
-- error computing mean position in particle set when there are no particles.
-- escape config file backup path in Windows.
-- implement bilinear interpolation on SVT, make interpolation generic regardless of data structure used.
-- skip only GB instead of GBA in RGB buffer readout in automatic tone mapping effect.
+- typo in German translation file. Fixes [#706](https://codeberg.org/gaiasky/gaiasky/issues/706).
+- remove unused configuration setting `scriptsLocation`.
+- tooltip and layout issues in datasets component.
+- invalid focus state in natural camera.
+- add object name checks to most API calls.
+- omit regular gamepad window bindings in gamepad configuration window.
+- first loading frame produced in VR with incorrect sizing.
+- connect visibility buttons in gamepad GUI to global visibility event, and add tooltips with name.
+- remove `IVRHeadsetView` interface from OpenVR initialization so that Gaia Sky works with OpenComposite, which translates OpenVR to OpenXR.
+- properly close file stream when done with them.
+- prevent hang on close due to daemon thread notify() calls.
+- incorrect filtering in slider backgrounds.
+- incorrect filtering in UI table baground image.
+- script with wrong loader name. Fixes [#703](https://codeberg.org/gaiasky/gaiasky/issues/703).
+
+## Code Refactoring
+
+- update VR controllers in their own system.
+- move VR UI classes to own package.
-## Refactoring
+## Documentation
-- move light glow code to own render pass class.
-- move shadow map code to own render pass class.
-- move source version to settings.
+- update API call fade in/out descriptions.