summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2022-06-21 09:59:17 +0200
committerlangurmonkey2022-06-21 09:59:17 +0200
commitad4bd2ca70be02fbbda01ba9294dcb67a773b3bc (patch)
tree575ce45ffb0e9a3614b8dcd1940e87fb71857297
parent8545d50b9cb5de201bbe941c2d4f48e6fa5ab2c6 (diff)
downloadaur-ad4bd2ca70be02fbbda01ba9294dcb67a773b3bc.tar.gz
Version 3.2.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--releasenotes.txt231
3 files changed, 23 insertions, 222 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1b045343e54..42388fdfe1c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.2.0.84c0fc728
+ pkgver = 3.2.1.41e4b0a5b
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.2.0.84c0fc728/gaiasky-3.2.0.84c0fc728.tar.gz
- md5sums = 72270a643c7ba1aa2e4a30a49faf0ff6
- sha256sums = 482206a79b06cbe44a5228b8f9c4c5b64da4eaed92434112f737b33a3825e60d
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.2.1.41e4b0a5b/gaiasky-3.2.1.41e4b0a5b.tar.gz
+ md5sums = 09dcb9ee8e697ee1455a73fd1f246333
+ sha256sums = 0b79ffaa66bebc3547a201426cfcf81f31b958c26a4f4b9bfd5c945a837d0575
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 31644568018a..651f64b1ad5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.2.0.84c0fc728
+pkgver=3.2.1.41e4b0a5b
pkgrel=1
epoch=2
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("72270a643c7ba1aa2e4a30a49faf0ff6")
-sha256sums=("482206a79b06cbe44a5228b8f9c4c5b64da4eaed92434112f737b33a3825e60d")
+md5sums=("09dcb9ee8e697ee1455a73fd1f246333")
+sha256sums=("0b79ffaa66bebc3547a201426cfcf81f31b958c26a4f4b9bfd5c945a837d0575")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index f3c0561d936f..05f8c1e03d1a 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,226 +1,27 @@
-# 3.2.0
+# Gaia Sky 3.2.1
## Bug Fixes
-- make sure direction and up vectors are orthogonal in camera transition call.
-- increase size star point buffer when needed.
-- null-check satellite attitude before getting quaternion. Fixes [#402](https://gitlab.com/langurmonkey/gaiasky/issues/402). [#402](https://gitlab.com/langurmonkey/gaiasky/issues/402)
-- empty tips may crash Gaia Sky at startup.
-- 'add scene graph object' event missing source object. Fixes [#400](https://gitlab.com/langurmonkey/gaiasky/issues/400). [#400](https://gitlab.com/langurmonkey/gaiasky/issues/400)
-- remove phase of pi radians in default-model orbital elements.
-- regression with libgdx 1.11.0 that caused vertical tooltips.
-- null-check settings in crash reporter.
-- workaround for libgdx backslash bug in asset manager. Fixes [#398](https://gitlab.com/langurmonkey/gaiasky/issues/398). [#398](https://gitlab.com/langurmonkey/gaiasky/issues/398)
-- hide system cursor correctly with GLFW until libgdx 1.10.1 is released.
-- use minimum widht for debug interface to prevent dynamic resizing depending on content.
-- correctly update label text when setting `SliderPlus` values.
-- correctly shut down background worker and manager threads so that JVM can finish gently.
-- add default values for orbit line and point colors.
-- configure crash window size with same code as regular window.
-- set argument of pericenter to zero when the epoch is not the reference epoch in the SSO converter for DR3.
-- compute mu automatically if period is set in orbital elements.
-- some data paths using forward slashes '/' instead of '\' on Windows.
-- big refactor that fixes the runtime activation and deactivation of both motion blur and ssr. Lots of little fixes and improvements to the render system.
-- add vr offset to reflection view direction.
-- VR controller info positioning, settings crash.
-- add null-checks for some OpenVR properties (required by Oculus 2). Add VR information in crash reporter. Fixes [#393](https://gitlab.com/langurmonkey/gaiasky/issues/393) (again). [#393](https://gitlab.com/langurmonkey/gaiasky/issues/393)
-- wrong scale factor in orbital elementss-based orbits in VR
-- update `VRControllerRole` values from `ETrackedControllerRole` from SteamVR spec. Fixes [#393](https://gitlab.com/langurmonkey/gaiasky/issues/393). [#393](https://gitlab.com/langurmonkey/gaiasky/issues/393)
-- broken `setObjectVisibility()` API call. Fixes [#391](https://gitlab.com/langurmonkey/gaiasky/issues/391). [#391](https://gitlab.com/langurmonkey/gaiasky/issues/391)
-- escape path before sending SAMP metadata. Fixes [#392](https://gitlab.com/langurmonkey/gaiasky/issues/392). [#392](https://gitlab.com/langurmonkey/gaiasky/issues/392)
-- regression adding bookmarks. Fixes [#390](https://gitlab.com/langurmonkey/gaiasky/issues/390). [#390](https://gitlab.com/langurmonkey/gaiasky/issues/390)
-- directional lights from stars still applied when stars are made invisible
-- restrict the rendering of pointer guides and cross-hairs in stereo and cubemap modes.
-- improve check box layout in preferences dialog
-- focus info interface width jitters when moving in free mode on occasions
-- Gaia fov modes with triangle-based stars
-- highlight dataset API call
-- particle dataset loading default size limits when using tris
-- issues with dataset loading via scripting
-- improve error handling in dataset manager
-- julian date algorithm
-- prevent repeated entries in search suggestions
-- dataset manager path handling on Windows
-- initial VR gui distance
-- lighting bug when multiple stars cast a light on an object
-- set encoding of i18n files to UTF-8, update formatting
-- layout of version line table
-- regression in apparent magnitude resource bundle key
-- effective temperature array initialization bug in STIL loader
-- regression in apparent magnitude resource bundle key
-- effective temperature array initialization bug in STIL loader
-- add notice whenever a `default-data` update is available. [#384](https://gitlab.com/langurmonkey/gaiasky/issues/384)
-- crosshair in cubemap, planetarium, stereo and VR modes
-- remove usage of deprecated Java APIs
-- do not add objects that already exist (have same names and same type) to scene graph
-- cloud rendering artifacts
-- reflections in tessellation shaders
-- reflected cubemap orientation (was upside down)
-- restore correct values on cancel in preferences dialog
-- show warn message when trying to select object from invisible dataset in search dialog
-- show warn message when trying to select object from invisible dataset in search dialog
-- getting particle position no longer results in null pointer
-- update directory permissions error message to make it easier to understand
-- default style of headline and subhead messages, as well as their positioning
-- JSON output of REST API server
-- reload data files when data path changes
-- data manager misbehavior when data location path is a symlink
-- rename old configuration files after conversion to new format
-- time offset (6711 yr) in Moon's position lookup
-- fix star clusters fade between model and billboard
-- color picker listener stops working after first click [#379](https://gitlab.com/langurmonkey/gaiasky/issues/379)
+- translate strings of filters, shapes, datasets and minimap. Fixes [#403](https://gitlab.com/langurmonkey/gaiasky/issues/403). [#403](https://gitlab.com/langurmonkey/gaiasky/issues/403)
+- filters crash with instanced star renderers.
+- moon orbits are recomputed more often.
+- modal windows made not collapsible by default.
+- hotkey tooltip backgrounds.
+- jump in Pluto's orbit due to deviation between full periods.
+- highlight 'all visible' setting in quad-based star renderers.
+- frame sequence number synchronized, value updated when opening preferences.
+- typo in Jupiter English translation file, add meshes to data descriptor file.
+- increase number of vertices of minimap shape renderer, fixes crash in heliosphere minimap.
+- break link in dataset manager if too long.
## Build System
-- force safe graphics mode on M1 macOS.
-- add aarch64 JRE to macOS bundle for M1 machines. Move to macOS single bundle archive from deprecated old single bundle.
-- downgrade jamepad to 2.0.14.2 as the newer 2.0.20.0 does not work with ARM macs.
-- upgrade to libgdx 1.11.0 and LWJGL 3.3.1 --- this adds M1 Mac support.
-- use default GC (G1) in favor of Shenandoah (only LTS).
-- remove run tasks, use '--args' gradle argument instead.
-- sign Windows packages with self-sigend certificate.
-- add Linux archive for itch.io.
-- add Windows archive to `install4j` template for uploading to itch.io.
-- update gradlew version
-- update install4j script to latest version, use bundled JRE for .deb, upgrade to Java 17
-- remove old run targets
-- remove deprecated features from build files
-- remove old run targets
-- remove deprecated features from build files
-- update gradle wrapper version to 7.3
-- upgrade jackson library version
-- remove gson dependency version
-- Java minimum version set to 15 in build script check
-- automatically generate release notes during build
-- update appimage JDK version to `16.0.2+7`
-
-## Code Refactoring
-
-- flatten object hierarchy by removing some classes, merging their functionality upwards.
-- abstract attitude loading system, remove gaia class, use heliotropic satellite.
-- add `I18nFormatter` to reformat i18n files.
-- remove useless number formatting infrastructure.
-- remove old date formatting infrastructure (desktop, html, mobile) in favor of a direct approach.
-- move update process to runnable, protect render lists from outer access.
-- improve service thread implementation.
-- move tips and funny texts to main bundle, add some dangling hardcoded strings to bundle, enable translation of keyboard keys.
-- move all text from -v flag to i18n keys.
-- remove some warnings, clean up code.
-- rename some packages and move some code around.
-- use bit mask instead of 64-bit integer as attributes mask so that we can register more than 64 attributes. Add proper 3-component specular color to materials. Add diffuse cubemaps for models and clouds. Fix a number of shader issues.
-- rename `u_environmentCubemap` to `u_diffuseCubemap` in shaders.
-- rename setting `data::skyboxLocation` to `data::reflectionSkyboxLocation`.
-- remove unused id from components, fix skybox orientation.
-- move double array to util package.
-- old milky way renderer converted to general-purpose billboard group infrastructure to enable representation of any quad-based point data.
-- remove unused and obsolete jython fix
-- improve shader combination and lookup (from ssr branch)
-- add source object to events by default
-
-## Documentation
-
-- update contributing document to reflect new objects file.
+- move namespace from 'gitlab.com/langurmonkey' to 'gitlab.com/gaiasky'.
+- docs project no longer a submodule.
## Features
-- add number of samples to orbit objects.
-- add popup notice when opening the keyframes window if component 'others' is not visible.
-- add full screen bit depth and refresh rate to fully qualify selected full screen modes.
-- improve layout and information of crash window.
-- add notice when there are no datasets.
-- add cyrillic characters to `main-font`, `font2d` and `font3d` fonts.
-- new API call: `setDatasetPointSizeMultiplier(String, Double)`.
-- enable translation of object names, and add first translation files for most common objects like planets, constellations, etc.
-- add scaffolding to translate welcome tips and funny sentences. Add Catalan translation for those.
-- complete catalan translation file, add neat options to translation status utility.
-- add buttons to launch preferences dialog and to quit at the bottom right of the welcome screen.
-- add translation status code and task, update catalan translation file.
-- add offline mode, activated in configuration file.
-- add meshes as datasets, connect dataset visibility to per-object visibility controls for meshes.
-- add specular, normal, emissive, metallic, roughness and height cubemap support to default and tessellation shaders.
-- add cubemap diffuse texturing capability to models.
-- implement the use of cubemaps in skyboxes. Fix cubemap reflection directions.
-- asteroids get full dataset controls (except for colormaps) like highlighting, coloring and sizing.
-- add catalog info goodies to asteroids catalogs.
-- add asteroids/sso catalog types.
-- expose SSR to preferences dialog, experimental section
-- screen space reflections Merge branch 'ssr'
-- add new red-blue anaglyph profile mode, additionally to the pre-existing red-cyan
-- add proxy configuration directly in Gaia Sky's config file
-- add dynamic resolution checkbox to preferences dialog
-- finish dynamic resolution implementation with an arbitrary number of levels
-- expand/collapse panes by clicking on title
-- add collapsible entry and use it for datasets in datasets component
-- add context menu to dataset items in dataset component
-- add GUI control to edit object fade time [ms]
-- improve layout and UX of datasets component
-- add roughness texture and value to normal shader, enable mipmaps in skybox
-- add popup notifications for certain important actions and events. These popup notifications can be closed by clicking on them, and they stay on screen for 8 seconds by default.
-- additional API call to load star datasets
-- save session log file to
-- add API call to set label colors
-- enable label colors for all objects. Always defaults to white
-- add method to inject transformation matrix directly into orbit, add change of basis matrix creation utility
-- allow spherical coordinates in StaticCoordinates, additional fixes
-- add background thread count and pool size to debug information
-- new 'force label visibility' flag for model objects. This flag causes the label of the object to always be rendered, regardless of the solid angle and other constraints. The flag is controlled by new button at the top of the focus information pane (bottom-right) and via two new scripting API calls.
-- simplify loading mechanism by joining catalog files with object files. No distinction is necessary anymore, for all of them work in the same way and are loaded by the same entities
-- add file list and scroll pane to dataset information in dataset manager
-- add pixel lighting shading to meshes
-- updated the Bulgarian translation
-- improve layout of welcome and loading GUIs
-- redesign dataset manager. The old download manager/catalog selection duo is phased out in favor of the new dataset manager. This is more usable and less confusing, while allowing for parallel downloads.
-- update splash
-- add camera distance from Sun in the camera section of the focus information pane
-- update welcome GUI background image
-- new non-constant-density fog shader which approximates physical fog much better than before
-- add an arbitrary number of load progress bars
-- enable loading internal JSON descriptor files from UI
-- interactive procedural generation of planetary surfaces, clouds and atmospheres
-- add interactive surface generation from the GUI
-- interactive procedural generation of cloud and atmosphere components from the GUI
-- add 'randomize all' function to totally randomize planet surfaces
-- add shift to biome LUT, improve procedural generation
-- generate normal map from elevation data if needed
-- planet generation with elevation, diffuse and specular textures
-- materials overhaul
-- get Gaia Sky ready for star systems with proper orbits
-- add `--headless` flag to run in headless mode (hidden window).
-- add API calls to configure and take screenshots
-- get Gaia Sky ready for star systems with proper orbits
-- add `--headless` flag to run in headless mode (hidden window).
-- add API calls to configure and take screenshots
-- add individual size scale factor to star/particle group datasets
-- improve mode switching dialogs with a few goodies and QOL updates
-- implement mosaic cubemaps, quad-based star group renderer
-- enable orbit trails in `GPU` VBO mode and remove the "orbit style" setting, for now the "GPU lines" line style setting uses VBOs
-- add 'New directory' button to file chooser, fix event propagation with generic dialogs
-- show release notes at startup after a version update
-- convert provider parameters to dataset options for STIL provider
-- add variability to close-up stars and star models
-- add variable stars as a new dataset type
-- add provider parameters to data providers
-- imporove CA,DE,ES translations
-- improve bookmarks, add missing i18n keys Fixes [#380](https://gitlab.com/langurmonkey/gaiasky/issues/380) [#380](https://gitlab.com/langurmonkey/gaiasky/issues/380)
-- shapes (spheres, cones, cylinders, etc.) of arbitrary sizes can now be added around any object, with the possibility of tracking the object's size. This is an extension of [#378](https://gitlab.com/langurmonkey/gaiasky/issues/378) which includes many more options plus an API entry point
-- add shapes around objects Fixes [#378](https://gitlab.com/langurmonkey/gaiasky/issues/378) [#378](https://gitlab.com/langurmonkey/gaiasky/issues/378)
-- add setting to select preferred units (ly/pc) [#377](https://gitlab.com/langurmonkey/gaiasky/issues/377)
-- add the possibility to track objects
-
-## Performance Improvements
-
-- separate UI reload from localized name updates.
-- improve performance of orbital elements particles by treating them as whole groups in the CPU using new model object and renderer.
-- initially size index hash maps to avoid resize operations
-
-## Style
-
-- consolidate normal shader vertex data into struct
-- organize imports in whole codebase
-
-## Merge Requests
-
-- Merge branch 'new-dataset-manager'
-- Merge branch 'points-triangles'
+- save configuration when closing dataset manager window.
+- use view angle instead of view angle apparent for `goToObject()` API call.