summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2024-01-29 10:03:47 +0100
committerlangurmonkey2024-01-29 10:03:47 +0100
commitaf4a6cb9829dd9f02f10212d3c84e811c2100256 (patch)
tree7d8b3d7f226357466f0b5211feedbe079ab576e5
parente23a319bc479a7f6d98b66db0b64ca5cb06d4c41 (diff)
downloadaur-af4a6cb9829dd9f02f10212d3c84e811c2100256.tar.gz
Bugfix release 3.5.8-2.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--releasenotes.txt48
3 files changed, 11 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45a2417cab5c..7d1562b7c10a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
pkgver = 3.5.8
- pkgrel = 1
+ pkgrel = 2
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.8.77b1dcbf6/gaiasky-3.5.8.77b1dcbf6.tar.gz
- md5sums = 60fd96c8fa6d5b2d141dcc0e3c76f0e2
- sha256sums = cf0de63e548ff9148702e4fbd7205c692d5a30d2847d6d83e6739983fa7f2602
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.8-2.4fd7a9705/gaiasky-3.5.8-2.4fd7a9705.tar.gz
+ md5sums = e526fac533d260e9f748fb19a0a214b8
+ sha256sums = abf64b60d8887e0f65bf94a806667a8d1051c7f82cae3f3fe433413192acc612
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 4c2381e6b86a..a4796367c68a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
pkgver=3.5.8
-pkgrel=1
+pkgrel=2
epoch=3
-versionstr=3.5.8.77b1dcbf6
+versionstr=3.5.8-2.4fd7a9705
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("60fd96c8fa6d5b2d141dcc0e3c76f0e2")
-sha256sums=("cf0de63e548ff9148702e4fbd7205c692d5a30d2847d6d83e6739983fa7f2602")
+md5sums=("e526fac533d260e9f748fb19a0a214b8")
+sha256sums=("abf64b60d8887e0f65bf94a806667a8d1051c7f82cae3f3fe433413192acc612")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 5709581821aa..6c9e8f1e3d9f 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,47 +1,5 @@
-# Gaia Sky 3.5.8
-
-## Features
-- add bookmarks section in gamepad GUI. See [#757](https://codeberg.org/gaiasky/gaiasky/issues/757).
-- cloud shadow projections on the surface of planets, for regular textures, cubemaps and SVT clouds.
-- add new `backupSettings()` and `restoreSettings()` API calls to back up and restore the entire settings in Gaia Sky from a script.
-- move 'star glow over objects' check box to Scene settings > Stars section.
-- add used, free, allocated and total memory to memory information window in help dialog.
-- enable eclipse outlines (for umbra and penumbra) by default in configuration file.
-- add application-level shader disk cache that stores binary shaders to disk to speed up application startup. Disabled by default, as most GPU drivers already do this on their own.
-- add binary particle group loader/writer to be able to load particles using an own binary format that loads much faster.
-- support `PARTICLE_EXT` attributes, additionally to the base `PARTICLE` attributes in the new binary format for particle groups.
-- increase number of divisions in shapes around objects from 15 to 35. Do not cull faces. See [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
-- enable exporting cubemap sides to image files, action bound to `F7` by default. Fixes [#753](https://codeberg.org/gaiasky/gaiasky/issues/753).
-- adjust constants so that the Sun size is accurate.
+# Gaia Sky 3.5.8-2
## Bug Fixes
-- use actual tree map for currently pressed keys in keyboard input controller, so that actions can be retrieved reliably.
-- do not activate surface mode (where the view follows the mouse location) with gamepad input.
-- layout and information in about/help dialog.
-- dataset detection to use dataset key by default instead of name.
-- apply graphics quality after restart. Remove graphics quality update events.
-- graphics quality update is now a 'needs restart' operation, otherwise the system crashes trying to load in new parameters, textures and so on. This is part of [#719](https://codeberg.org/gaiasky/gaiasky/issues/719).
-- increase constellation and boundaries line width to prevent rastering artifacts. This is part of [#719](https://codeberg.org/gaiasky/gaiasky/issues/719).
-- star flickering issues due to quad sizes mended by setting a minimum quad solid angle roughly equal to the pixel size of the back-buffer. Fixes [#719](https://codeberg.org/gaiasky/gaiasky/issues/719).
-- tooltips in number validators using the `MAX_VALUE` or `MIN_VALUE` should use infinity instead. Part of [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
-- add orientation to shape dialog (camera, equatorial, ecliptic, galactic). Fixes [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
-- remove all shapes [& around object] actually removes all shapes and not only the first in the list. This is part of [#756](https://codeberg.org/gaiasky/gaiasky/issues/756).
-- default to scientific notation only when abs(num) > 9999. Fixes [#755](https://codeberg.org/gaiasky/gaiasky/issues/755).
-- possible null pointer exceptions in OpenXR driver.
-- enable breaking string sequences at forward and backward slashes, as well as whitespaces. This prevents overflown content in the error dialog in certain cases.
-- run actual octant update code in the main thread.
-- particle sizing and size limits in the loader.
-
-## Performance Improvements
-- remove unnecessary synchronized blocks from index.
-- use parallel sort instead of regular single-threaded sort for particle and star sets.
-- make sure that unseen stars (i.e. computed final color is 0) do not take up fragment shader resources.
-
-## Code Refactoring
-- rename attributes of UCD and UCDParser to comport with the global style.
-
-## Build System
-- upgrade to gradle 8.5.
-
-## Merge Requests
-- Merge branch 'star-shading'
+- number of reported layers by OpenXR driver can be 0, otherwise app does not start. Fixes [#763](https://codeberg.org/gaiasky/gaiasky/issues/763).
+- visual settings reset operation implemented in one place only.