summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2023-11-29 09:22:19 +0100
committerlangurmonkey2023-11-29 09:22:19 +0100
commitb3669da8ee78b6c5cc1b94f17780e89e5a8b2e4f (patch)
tree127062875696bad6e187acb40cb6c819efe035d2
parentc7f031b2fe7155bb98358f6d0eacd49c423f1072 (diff)
downloadaur-b3669da8ee78b6c5cc1b94f17780e89e5a8b2e4f.tar.gz
Version 3.5.7-3.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--releasenotes.txt25
3 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5bb5da9b41..a2805962ca00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
pkgver = 3.5.7
- pkgrel = 2
+ pkgrel = 3
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.7-2.987bbd941/gaiasky-3.5.7-2.987bbd941.tar.gz
- md5sums = 6e8b0f093061b820e0cf92582f6b5720
- sha256sums = c1725ea7b5fef45ab435c95888156b0040b3887cc636cad4e4e928d272489fa9
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.7-3.8be0b0add/gaiasky-3.5.7-3.8be0b0add.tar.gz
+ md5sums = 4d04dc90728f3bbc020d989213f7c123
+ sha256sums = 5ffc2dfd3660ad77a8d3d10f8836e146cbf08bce4cdbc6612a8ee8870e6186e1
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 07152a3ccd7a..7702c69afb5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
pkgver=3.5.7
-pkgrel=2
+pkgrel=3
epoch=3
-versionstr=3.5.7-2.987bbd941
+versionstr=3.5.7-3.8be0b0add
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("6e8b0f093061b820e0cf92582f6b5720")
-sha256sums=("c1725ea7b5fef45ab435c95888156b0040b3887cc636cad4e4e928d272489fa9")
+md5sums=("4d04dc90728f3bbc020d989213f7c123")
+sha256sums=("5ffc2dfd3660ad77a8d3d10f8836e146cbf08bce4cdbc6612a8ee8870e6186e1")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 900f6cad7bcd..5c492072e1b6 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,19 +1,10 @@
-# Gaia Sky 3.5.7-2
-
-## Features
-- display stars with missing radial velocity information as 'N/A' instead of 0. This requires a re-generation of the catalogs.
-- add oblateness to sphere parameters.
-- artificially increase the number of labels setting in star groups of compact octrees (fewer than 3 nodes).
-- enable `numLabels` attribute for star set objects in order to control the number of labels rendered for a given star set.
-- add script to generate gitstats from repository.
+# Gaia Sky 3.5.7-3
## Bug Fixes
-- restore octree drawing functionality.
-- always initialize star group sorting data (not only if 'numLabels' = 0), otherwise the system may crash, for it is used elsewhere for other purposes.
-- check active list in star set exists before using.
-- free XR events after using them.
-- make sure that a mesh exists before disposing.
-- rename `scene::star::group::numLabel` configuration property to `scene::star::group::numLabels`.
-
-## Build System
-- update gradle wrapper script files and jar.
+- columns corresponding to the same UCD maintain the order of appearance in the source table when used.
+- use concurrent hash set in 'selecting' list in the OpenXR input listener to prevent concurrent modification errors.
+- resizing log window does not resize contents. Fixes [#749](https://codeberg.org/gaiasky/gaiasky/issues/749).
+- prevent getting name from second closest object if it is invalid. Fixes [#750](https://codeberg.org/gaiasky/gaiasky/issues/750).
+- use logical keys instead of key codes by converting GDX's codes to GLFW, which uses the logical keyboard layout. Fixes [#748](https://codeberg.org/gaiasky/gaiasky/issues/748).
+- rename makefile, update build script to detect `/opt/gaiasky` installation.
+- use default mappings file if the configured one does not exist.