summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2023-10-20 08:48:38 +0200
committerlangurmonkey2023-10-20 08:48:38 +0200
commitb81b87ffc2d9985ac840b5bf97dcf984d1590946 (patch)
treefdeb320ec602735f194d5c7c696deedf79c15375
parent7f4758f7f7a8e57ba9df54970bb9a2ec0e763166 (diff)
downloadaur-b81b87ffc2d9985ac840b5bf97dcf984d1590946.tar.gz
Version 3.5.6.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--releasenotes.txt31
3 files changed, 37 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 477f94ab782f..58e9364b8162 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.5.5
- pkgrel = 2
+ pkgver = 3.5.6
+ pkgrel = 1
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.5-2.f09289b66/gaiasky-3.5.5-2.f09289b66.tar.gz
- md5sums = 3b6799d564fe27fccd5862f0b11ab910
- sha256sums = 012c8ca4ecb0dd2e3322d4e12fa9943de8803a5e50b005c057beeb420703460a
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.6.c061e75f5/gaiasky-3.5.6.c061e75f5.tar.gz
+ md5sums = 4f67a16ecd45b7882f14106ecb7380ab
+ sha256sums = c82c7e02fa7decb94c8d31d521d95602ae660b118d63d1a9263f83fc95526ebf
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 4ac870a7ed73..a6d06e833a58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.5.5
-pkgrel=2
+pkgver=3.5.6
+pkgrel=1
epoch=3
-versionstr=3.5.5-2.f09289b66
+versionstr=3.5.6.c061e75f5
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("3b6799d564fe27fccd5862f0b11ab910")
-sha256sums=("012c8ca4ecb0dd2e3322d4e12fa9943de8803a5e50b005c057beeb420703460a")
+md5sums=("4f67a16ecd45b7882f14106ecb7380ab")
+sha256sums=("c82c7e02fa7decb94c8d31d521d95602ae660b118d63d1a9263f83fc95526ebf")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 55c867c6b5b8..1733ba140926 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,8 +1,31 @@
-# Gaia Sky 3.5.5-2
+# Gaia Sky 3.5.6
+
+## Features
+- add film grain filter (disabled by default).
+- set a maximum age for `.part` download files of 6 hours.
+- improve recursive grid with travelling pulses and a noise mask.
+- add 'animate' setting to recursive grid preferences to toggle animation on and off.
+- add checkbox to control recursive grid animation.
+- add initial notice about Gaia Sky contacting the server to get the dataset updates list.
+- improve shader compilation error handling.
+- enable elevation (height) representation without tessellation in a new 'regular' mode. This is the new default mode, as tessellation is a bit to taxing on old and integrated GPUs.
+- discontinue parallax mapping elevation type; the new vertex displacement type supersedes it.
+- add full support for point lights, and use them for stars.
+- true depth-tested close-by stars, also working with light glow enabled.
## Bug Fixes
-- crash fetching entity elevation due to the focus not being set yet.
+- prevent creation of background blur object, as camera motion blur was disabled a few versions ago.
+- use predicted position for tracking objects.
+- 'reload defaults' button in visual settings component actually sets the default value to the elevation multiplier slider.
+- new star shader in intel GPUs.
+- mouse coordinates collision with objects when back buffer scale != 1.
+
+## Code Refactoring
+- move GLSL snippet shader chunks to own directory `assets/shader/snippet`.
+- rename shaders from 'normal' to 'pbr'.
## Build System
-- add check for revision >= 2 in release script.
-- automate creation of HTML downloads table and properly use 'pkgver' and 'pkgrel' fields in AUR package.
+- set `-source` to 16 in gradle build script to enable pattern matching in instanceof.
+
+## Style
+- code style now formats Javadoc comments.