summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2023-11-21 12:32:29 +0100
committerlangurmonkey2023-11-21 12:32:29 +0100
commitc7f031b2fe7155bb98358f6d0eacd49c423f1072 (patch)
treeab8c07d22f2fc38a6c94270083a5551b2083f93e
parent55bb9099b8a6e1284855277e4e1d135e9d6571ff (diff)
downloadaur-c7f031b2fe7155bb98358f6d0eacd49c423f1072.tar.gz
Version 3.5.7-2 (fixed).
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--releasenotes.txt37
3 files changed, 19 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 115a52a61f1f..be5bb5da9b41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.7-2.9271e6cdf/gaiasky-3.5.7-2.9271e6cdf.tar.gz
- md5sums = 2a8094355d2dba8f30a1b2a11a2a624d
- sha256sums = f9358cfc8c545b586bbc23b4f8085157f16298cb8b1e19b611b2521f536952ff
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.7-2.987bbd941/gaiasky-3.5.7-2.987bbd941.tar.gz
+ md5sums = 6e8b0f093061b820e0cf92582f6b5720
+ sha256sums = c1725ea7b5fef45ab435c95888156b0040b3887cc636cad4e4e928d272489fa9
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index d147ffea1caf..07152a3ccd7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=gaiasky
pkgver=3.5.7
pkgrel=2
epoch=3
-versionstr=3.5.7-2.9271e6cdf
+versionstr=3.5.7-2.987bbd941
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("2a8094355d2dba8f30a1b2a11a2a624d")
-sha256sums=("f9358cfc8c545b586bbc23b4f8085157f16298cb8b1e19b611b2521f536952ff")
+md5sums=("6e8b0f093061b820e0cf92582f6b5720")
+sha256sums=("c1725ea7b5fef45ab435c95888156b0040b3887cc636cad4e4e928d272489fa9")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 93be3c626478..900f6cad7bcd 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,30 +1,19 @@
-# Gaia Sky 3.5.7
+# Gaia Sky 3.5.7-2
## Features
-- add surface exploration mode for planets, where the camera moves relative to the position of the pointer when close to a planet or moon.
-- add floating-point completion rates to billboard datasets.
-- combine SSR with cubemap reflections to fill in parts that reflect to off-screen locations.
-- add Debian build files. Add Makefile. Add `createDebian` task to gradle build script.
-- updated Bulgarian translation
+- display stars with missing radial velocity information as 'N/A' instead of 0. This requires a re-generation of the catalogs.
+- add oblateness to sphere parameters.
+- artificially increase the number of labels setting in star groups of compact octrees (fewer than 3 nodes).
+- enable `numLabels` attribute for star set objects in order to control the number of labels rendered for a given star set.
+- add script to generate gitstats from repository.
## Bug Fixes
-- crash when enabling 'Others' component type at startup in VR.
-- sizing of datasets scroll pane with expand/collapse groups is incorrect in some instances.
-- add free space check before downloads, and clean up properly after a failed extraction operation. Fixes [#744](https://codeberg.org/gaiasky/gaiasky/issues/744).
-- auto-scroll to target when cycling through UI elements with gamepad left stick. Selection and action with gamepad in dataset manager window.
-- zero-length keyframed path crashes the 'normalize times' action. Fixes [#741](https://codeberg.org/gaiasky/gaiasky/issues/741).
-- add missing, untranslated strings to I18N files. Fixes [#740](https://codeberg.org/gaiasky/gaiasky/issues/740).
-- start and dataset manager buttons do not scale horizontally with content.
-- ascending node parameter in rotation component does not apply correctly. Bump source version to 3.5.7, for new data is needed.
-- recursive tile lookup in sparse virtual textures module does not work correctly.
-- prevent SVT level overflows, and prompt for restart when tile cache size is modified in preferences.
-- remove custom amount of vertical scroll in scroll panes. Scrolling should now be much easier.
+- restore octree drawing functionality.
+- always initialize star group sorting data (not only if 'numLabels' = 0), otherwise the system may crash, for it is used elsewhere for other purposes.
+- check active list in star set exists before using.
+- free XR events after using them.
+- make sure that a mesh exists before disposing.
+- rename `scene::star::group::numLabel` configuration property to `scene::star::group::numLabels`.
## Build System
-- upgrade to LibGDX 1.12.1 and LWJGL 3.3.3.
-
-## Style
-- add missing deprecated tags to deprecated items.
-
-## Merge Requests
-- Merge branch 'RacerBG-bg-update'
+- update gradle wrapper script files and jar.