summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2020-07-07 12:28:19 +0200
committerlangurmonkey2020-07-07 12:28:19 +0200
commitdf9bddd9527e720a2d3dcda64aeb9c275968ef72 (patch)
treebf138e32ed08de9321cb0926dcea8b153698abb6
parent1fbc61fa74c7125ac72d27ffad84f6f74136f18b (diff)
downloadaur-df9bddd9527e720a2d3dcda64aeb9c275968ef72.tar.gz
Version 2.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md60
-rw-r--r--PKGBUILD4
3 files changed, 64 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 065961619158..78d03d365f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 2.2.6.e6ef9256e
+ pkgver = 2.3.0.c68fca318
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre11-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.2.6.e6ef9256e/gaiasky-2.2.6.e6ef9256e.tar.gz
- md5sums = 6b36d00e08c738c7671f8dc35fd28e2c
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.3.0.c68fca318/gaiasky-2.3.0.c68fca318.tar.gz
+ md5sums = 31fa445192b2cb9fd064d2109c9246dd
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 624e825a2737..86d1fac599c0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,64 @@
<a name="unreleased"></a>
## [Unreleased](https://gitlab.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.6...HEAD)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.3.0...HEAD)
+
+
+<a name="2.3.0"></a>
+## [2.3.0](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.6) (2020-07-07)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.6...2.3.0)
+
+### Bug Fixes
+- update name and source version number
+- error in lib_math shadier code
+- remove default fade-out values in star groups, added to loading dialog
+- interpolation limits in math shader library
+- initial update not performed on fade node children if ct is off
+- uncomment unhandled event debug info
+- windows crash due to stars '*' not being accepted in paths
+- add notice concerning the selection of more than one Gaia catalog
+- changing focus to different object in same particle group works
+- default value for magnitude scale is 0, fix float validator range
+- disable depth test for billboards
+- inconsistencies with STAR_MIN_OPACITY_CMD
+- ensure non-empty field in search dialog
+
+### Build System
+- fix build with text folder
+- remove all absolute paths to project folder
+
+### Code Refactoring
+- observer fields final, package name typo
+- clean up gaia hacks, ray marching plubming
+- post-processing subsystem made more generic
+- move render system to java collections and streams
+
+### Documentation
+- improve readme listings
+- update acknowledgements
+- add iconic license
+- add package-info package documentation, update changelog
+
+### Features
+- update server to HTTPS
+- add call to set 'all visible' dataset property
+- add 'invert X look axis' as well as Y
+- axis power value and sensitivity in config window
+- sliders now contain value label
+- sensitivity sliders for game controllers
+- add tips to loading screen
+- post-processor to accept external shader code in the data folder
+- ray marching shaders
+- raymarching post-processing shaders
+- complete move to SDL-back controllers
+- full refactoring of controller mappings system
+- interactive gamepad configuration
+- add support for emissive textures, fix obj loading issue
+- API call to modify solid angle threshold of orbits
+- add properties for some star settings
+- adjust size of star billboards
+- add API call to scale orbits. Use with caution!
+- distances in AU and parsec start at 0.1 mark
+- add star brightness power setter to API
<a name="2.2.6"></a>
diff --git a/PKGBUILD b/PKGBUILD
index 34793f9d2762..8f286117bc32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=2.2.6.e6ef9256e
+pkgver=2.3.0.c68fca318
pkgrel=1
epoch=2
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -21,7 +21,7 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("6b36d00e08c738c7671f8dc35fd28e2c")
+md5sums=("31fa445192b2cb9fd064d2109c9246dd")
validpgpkeys=()
prepare() {