summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2024-02-19 15:12:02 +0100
committerlangurmonkey2024-02-19 15:12:02 +0100
commitf6681e292d2cdca9d88601b5cc2ffc20860651e1 (patch)
treed9a1af3c42345a7a372f9e61a08939ec81638a99
parent83bdb99b6932f18da163e3c0b9de39e51c835790 (diff)
downloadaur-f6681e292d2cdca9d88601b5cc2ffc20860651e1.tar.gz
Version 3.5.9.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--releasenotes.txt25
3 files changed, 33 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d706359511ca..3ae83335b609 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.5.8
- pkgrel = 3
+ pkgver = 3.5.9
+ pkgrel = 1
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.8-3.600deaa6a/gaiasky-3.5.8-3.600deaa6a.tar.gz
- md5sums = c5190aac7c5e689a2a80b8e063102070
- sha256sums = d2bc7fe5ba93a2703b85c8492fadbe80226bc3251ef859660bb048b6d47ab11d
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.9.51d1305ab/gaiasky-3.5.9.51d1305ab.tar.gz
+ md5sums = 35c1dcb627fef650ff1a36df31a6ff66
+ sha256sums = 196891a59f7cd369ecf2282a24c2f5b523d306f3bc8fe90d71f3e3a7168bdcb4
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 4fbd24cadc1b..a090a4029121 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.5.8
-pkgrel=3
+pkgver=3.5.9
+pkgrel=1
epoch=3
-versionstr=3.5.8-3.600deaa6a
+versionstr=3.5.9.51d1305ab
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("c5190aac7c5e689a2a80b8e063102070")
-sha256sums=("d2bc7fe5ba93a2703b85c8492fadbe80226bc3251ef859660bb048b6d47ab11d")
+md5sums=("35c1dcb627fef650ff1a36df31a6ff66")
+sha256sums=("196891a59f7cd369ecf2282a24c2f5b523d306f3bc8fe90d71f3e3a7168bdcb4")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index e2386fa81c1d..9af0de6220ef 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,4 +1,25 @@
-# Gaia Sky 3.5.8-3
+# Gaia Sky 3.5.9
+
+## Features
+- add support for arbitrary affine transformations to datasets, and add controls to create and edit them in the datasets pane.
+- separate filters from dataset preferences into their own button/window in datasets pane.
+- improve layout of the filters window by moving the 'add' button to the top and adding a scroll pane in the content.
+- improve default window skin by adding some padding and a better sprite.
+- rename dataset preferences to dataset visual settings. It now contains some sliders to modify the point size and the min/max solid angles. It does not contain filters or dataset information anymore, as those were extracted to their own dialogs.
+- add affine transformations to all datasets (particle group, star group, variable star group, billboard group, orbit elements group). These transformations are applied in the shaders so that they can be updated on the fly. The billboard group object has been moved inside the generic catalog archetype; the Milky Way appears as a dataset now.
+- add min/max particle solid angle size and number of labels to particle dataset load dialog.
+- add support for additional texture(s) in raymarching shaders.
+- do not force safe mode on Macs powered by apple silicon anymore.
## Bug Fixes
-- make sure a focus' star ancestor exists before trying to get its parenthood in the octree.
+- remove support for cloud SVT shadows, as this necessitates the cloud SVT and the diffuse SVT to be exactly the same (same depth, same available tiles, etc.), and this is not *usually* the case.
+- concurrency error in procedural generation progress bar update actions.
+- present filter results in dataset manager in expanded panes.
+- prevent the creation of multiple dataset preferences window for the same dataset.
+- prevent NPE crash during the creation of the error dialog. Part of [#765](https://codeberg.org/gaiasky/gaiasky/issues/765).
+- prevent null pointer when updating star sets. Fixes [#766](https://codeberg.org/gaiasky/gaiasky/issues/766).
+- typo in French translation.
+- appimage actually includes unpacked JRE distribution correctly.
+
+## Build System
+- add pgp signature to build process instead of checksums.