summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommaso Sardelli2016-08-11 16:58:37 +0200
committerTommaso Sardelli2016-08-11 16:58:37 +0200
commit7ef55793c7c24d622e0a49cbe212d003b135c72d (patch)
tree6dc46822b338692a82d77e2f5df8b2a69d4f0c6d
parentaf527f66c543f2f44c3f44904a3dbc32bd639b03 (diff)
downloadaur-7ef55793c7c24d622e0a49cbe212d003b135c72d.tar.gz
Add missing python2-setuptools dependency and remove unnecessary files from the final package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 077e70d60f4b..835922e2f742 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = gajim-plugin-omemo-git
pkgdesc = Gajim plugin for OMEMO Multi-End Message and Object Encryption.
- pkgver = 0.5.1.r93.g735ff65
+ pkgver = 0.8.1.r2.g3a38dcb
pkgrel = 1
url = https://github.com/omemo/gajim-omemo
arch = any
license = GPL
depends = gajim
+ depends = python2-setuptools
depends = python2-cryptography
depends = python2-axolotl-git
provides = gajim-plugin-omemo
diff --git a/PKGBUILD b/PKGBUILD
index 4156cb0ee743..1ba7a3f1cd42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=gajim-plugin-omemo-git
_pkgname=gajim-omemo
-pkgver=0.5.1.r93.g735ff65
+pkgver=0.8.1.r2.g3a38dcb
pkgrel=1
pkgdesc="Gajim plugin for OMEMO Multi-End Message and Object Encryption."
arch=(any)
url="https://github.com/omemo/${_pkgname}"
license=('GPL')
-depends=("gajim" "python2-cryptography" "python2-axolotl-git")
+depends=("gajim" "python2-setuptools" "python2-cryptography" "python2-axolotl-git")
provides=('gajim-plugin-omemo')
conflicts=('gajim-plugin-omemo')
source=("git://github.com/omemo/gajim-omemo")
@@ -24,6 +24,7 @@ pkgver() {
package() {
cd $srcdir/gajim-omemo
+ rm -r CHANGELOG COPYING doc pkgs README.md
install -d ${pkgdir}/usr/share/gajim/plugins/omemo
cp -r * ${pkgdir}/usr/share/gajim/plugins/omemo/
}