summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2019-02-13 13:41:38 +0100
committerBjoern Franke2019-02-13 13:41:38 +0100
commit7a7e7989f4b7b2b8ff1433f62048c3719af4f24e (patch)
tree7cbfc3f5daf3fe9a04ccfa706ee249c2e4fcf8e9
downloadaur-7a7e7989f4b7b2b8ff1433f62048c3719af4f24e.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bcd9d85c516
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gajim-plugin-urlimagepreview
+ pkgdesc = Gajim plugin which displays a preview of links to images
+ pkgver = 2.3.33
+ pkgrel = 1
+ url = https://dev.gajim.org/gajim/gajim-plugins/wikis/urlimagepreviewplugin
+ arch = any
+ license = GPL
+ depends = gajim>=1.1.91
+ depends = gajim<=1.2.90
+ depends = python-setuptools
+ depends = python-cryptography
+ provides = gajim-plugin-urlimagepreview
+ source = https://ftp.gajim.org/plugins_releases/url_image_preview_2.3.33.zip
+ sha512sums = e5a3e5d4d7b4e86ce087f9f85c355b96c7ceca2a3fb00dee5838263211b1b4d28b8d60db2407291435c9f6ea7ac42e808926aa389d0924182691b3ace6100a8d
+
+pkgname = gajim-plugin-urlimagepreview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbf8f06d0add
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Bjoern Franke <bjo@nord-west.org>
+
+pkgname=gajim-plugin-urlimagepreview
+_pkgname=url_image_preview
+pkgver=2.3.33
+pkgrel=1
+pkgdesc="Gajim plugin which displays a preview of links to images"
+arch=(any)
+url="https://dev.gajim.org/gajim/gajim-plugins/wikis/urlimagepreviewplugin"
+license=('GPL')
+depends=("gajim>=1.1.91" "gajim<=1.2.90" "python-setuptools" "python-cryptography")
+provides=('gajim-plugin-urlimagepreview')
+source=("https://ftp.gajim.org/plugins_releases/${_pkgname}_${pkgver}.zip")
+sha512sums=('e5a3e5d4d7b4e86ce087f9f85c355b96c7ceca2a3fb00dee5838263211b1b4d28b8d60db2407291435c9f6ea7ac42e808926aa389d0924182691b3ace6100a8d')
+
+package() {
+ cd ${srcdir}/${_pkgname}
+
+ # Remove unnecessary files
+ rm -r CHANGELOG COPYING
+
+ # Install the plugin
+ install -d ${pkgdir}/usr/lib/python3.7/site-packages/gajim/data/plugins/${_pkgname}
+ cp -r * ${pkgdir}/usr/lib/python3.7/site-packages/gajim/data/plugins/${_pkgname}/
+}
+
+# vim:set ts=2 sw=2 et: