summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAve O2018-07-26 02:07:40 +0300
committerAve O2018-07-26 02:07:40 +0300
commit50bb55d1b0c2dc4407d289e0fb534287f9a6e345 (patch)
treef8044589279e6cf1dd3ea007625950857670a7ea
downloadaur-50bb55d1b0c2dc4407d289e0fb534287f9a6e345.tar.gz
Initial AUR release for Gajimbo
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD52
2 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6af86bee01eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = gajimbo-git
+ pkgdesc = A fork of Gajim with various enhancements, written in Python with GTK+
+ pkgver = 9ac12a252a
+ pkgrel = 1
+ url = https://git.a3.pm/a/gajimbo
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-gobject
+ depends = python-pyopenssl
+ depends = hicolor-icon-theme
+ depends = python-pyasn1
+ depends = python-nbxmpp
+ depends = python-cairo
+ depends = python-keyring
+ depends = python-distro
+ optdepends = python-dbus: for gajim-remote and zeroconf support
+ optdepends = farstream: for video/voice support
+ optdepends = gst-plugins-good: for video/voice support
+ optdepends = gst-plugins-bad: for video/voice support
+ optdepends = gst-plugins-ugly: for video/voice support
+ optdepends = gst-libav: for video/voice support
+ optdepends = gst-python: for video/voice support
+ optdepends = gspell: for spell checking support
+ optdepends = libxss: for idle time checking on X11
+ optdepends = notification-daemon: for desktop notifications
+ optdepends = gnome-keyring: store passwords encrypted in GNOME Keyring
+ optdepends = kded: store passwords encrypted in KSecretService
+ optdepends = python-crypto: support for E2E encryption
+ optdepends = python-docutils: for RST generator support
+ optdepends = gupnp-igd: for UPnP-IGD support
+ optdepends = geoclue2: for sharing your location
+ provides = gajim
+ conflicts = gajim
+ conflicts = gajim-hg
+ conflicts = gajim-svn
+ conflicts = gajim-git
+ source = gajimbo::git+https://git.a3.pm/a/gajimbo
+ md5sums = SKIP
+
+pkgname = gajimbo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2ebcff9d334
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ave Ozkal <aurpub@ave.zone>
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Bjoern Franke <bjo at nord-west.org>
+# Contributor: Lev Lybin <lev.lybin@gmail.com>
+# Contributor: Benjamin Richter <br@waldteufel-online.net>
+# Contributor: Changaco <changaco@changaco.net>
+# Contributor: Artyom Smirnov <smirnoffjr@gmail.com>
+# Contributor: Michael Pusterhofer <pusterhofer [at] student [dot] tugraz [dot] at>
+
+_name=gajimbo
+pkgname="$_name-git"
+pkgver=9ac12a252a
+pkgrel=1
+pkgdesc="A fork of Gajim with various enhancements, written in Python with GTK+"
+arch=('any')
+url="https://git.a3.pm/a/gajimbo"
+license=('GPL3')
+depends=('python-gobject' 'python-pyopenssl' 'hicolor-icon-theme'
+ 'python-pyasn1' 'python-nbxmpp' 'python-cairo' 'python-keyring'
+ 'python-distro')
+makedepends=('git' 'python-setuptools')
+optdepends=('python-dbus: for gajim-remote and zeroconf support'
+ 'farstream: for video/voice support'
+ 'gst-plugins-good: for video/voice support'
+ 'gst-plugins-bad: for video/voice support'
+ 'gst-plugins-ugly: for video/voice support'
+ 'gst-libav: for video/voice support'
+ 'gst-python: for video/voice support'
+ 'gspell: for spell checking support'
+ 'libxss: for idle time checking on X11'
+ 'notification-daemon: for desktop notifications'
+ 'gnome-keyring: store passwords encrypted in GNOME Keyring'
+ 'kded: store passwords encrypted in KSecretService'
+ 'python-crypto: support for E2E encryption'
+ 'python-docutils: for RST generator support'
+ 'gupnp-igd: for UPnP-IGD support'
+ 'geoclue2: for sharing your location')
+provides=('gajim')
+conflicts=('gajim' 'gajim-hg' 'gajim-svn' 'gajim-git')
+source=("$_name::git+https://git.a3.pm/a/gajimbo")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_name
+ git rev-parse HEAD | cut -c1-10
+}
+
+package() {
+ cd $_name
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+