summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-12-02 12:42:38 +0100
committerJaroslav Lichtblau2014-12-02 12:42:38 +0100
commit26e913a21348fd74e898a0259e8887be4a4ccee4 (patch)
treea46013b89923057b2b87131695a57588d4889bf1
parent5fda468b0097ec4d28a9844f4ced4201a25478bd (diff)
downloadaur-26e913a21348fd74e898a0259e8887be4a4ccee4.tar.gz
galapix-0.2.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--galapix-gcc44.patch66
-rwxr-xr-ximagemagick_plugin.patch30
-rwxr-xr-xpng_string_fix.patch11
5 files changed, 70 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c93f77a6d81..6af746e7aa81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = galapix
pkgdesc = A zoomable image viewer for large collections of images
- pkgver = 0.1.2
+ pkgver = 0.2.1
pkgrel = 1
url = http://code.google.com/p/galapix/
arch = i686
@@ -10,7 +10,7 @@ pkgbase = galapix
makedepends = patch
makedepends = gtkglextmm
makedepends = libglademm
- depends = boost
+ makedepends = boost
depends = curl
depends = glew
depends = imagemagick
@@ -20,10 +20,14 @@ pkgbase = galapix
depends = mesa
depends = sdl
depends = sqlite3
- source = http://galapix.googlecode.com/files/galapix-0.1.2.tar.bz2
- source = galapix-gcc44.patch
- md5sums = f55fa7c87dabe132b3493220fa0d9d8d
- md5sums = 8189e68e656a82e890242395416f9e34
+ optdepends = xcftools: XCF format support
+ optdepends = gimp-ufraw: RAW format support
+ source = http://galapix.googlecode.com/archive/galapix-0.2.1.tar.gz
+ source = imagemagick_plugin.patch
+ source = png_string_fix.patch
+ md5sums = d58ef6c5e1f51efe37886a734750b9d5
+ md5sums = 9f2397caa6bea257ca0cd09a31f96dbf
+ md5sums = 34f0386d3247edc62e3ff4e55892d286
pkgname = galapix
diff --git a/PKGBUILD b/PKGBUILD
index 21ef5d97da6b..4c5d5ec84f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=galapix
-pkgver=0.1.2
+pkgver=0.2.1
pkgrel=1
pkgdesc="A zoomable image viewer for large collections of images"
arch=('i686' 'x86_64')
url="http://code.google.com/p/galapix/"
license=('GPL3')
-depends=('boost' 'curl' 'glew' 'imagemagick' 'libexif' 'libjpeg' 'libpng' 'mesa' 'sdl' 'sqlite3')
-makedepends=('scons' 'patch' 'gtkglextmm' 'libglademm')
-source=(http://galapix.googlecode.com/files/$pkgname-$pkgver.tar.bz2 \
- $pkgname-gcc44.patch)
-md5sums=('f55fa7c87dabe132b3493220fa0d9d8d'
- '8189e68e656a82e890242395416f9e34')
+depends=('curl' 'glew' 'imagemagick' 'libexif' 'libjpeg' 'libpng' 'mesa' 'sdl' 'sqlite3')
+makedepends=('scons' 'patch' 'gtkglextmm' 'libglademm' 'boost')
+optdepends=('xcftools: XCF format support'
+ 'gimp-ufraw: RAW format support')
+source=(http://galapix.googlecode.com/archive/$pkgname-$pkgver.tar.gz
+ imagemagick_plugin.patch png_string_fix.patch)
+md5sums=('d58ef6c5e1f51efe37886a734750b9d5'
+ '9f2397caa6bea257ca0cd09a31f96dbf'
+ '34f0386d3247edc62e3ff4e55892d286')
-build() {
- cd ${srcdir}/$pkgname-$pkgver
-
- patch -Np1 -i ${srcdir}/$pkgname-gcc44.patch
+prepare() {
+ cd "${srcdir}"/$pkgname-$pkgname-$pkgver
+ patch -Np0 -i "${srcdir}"/imagemagick_plugin.patch
+ patch -Np0 -i "${srcdir}"/png_string_fix.patch
+}
+build() {
+ cd "${srcdir}"/$pkgname-$pkgname-$pkgver
scons
}
package() {
- cd ${srcdir}/$pkgname-$pkgver
-
- install -D -m755 build/$pkgname.sdl ${pkgdir}/usr/bin/$pkgname
+ cd "${srcdir}"/$pkgname-$pkgname-$pkgver
+ install -Dm755 build/$pkgname.sdl "${pkgdir}"/usr/bin/$pkgname
}
diff --git a/galapix-gcc44.patch b/galapix-gcc44.patch
deleted file mode 100644
index a2545a8a2f8f..000000000000
--- a/galapix-gcc44.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -ruN galapix-0.1.2-orig/src/galapix/workspace.cpp galapix-0.1.2/src/galapix/workspace.cpp
---- galapix-0.1.2-orig/src/galapix/workspace.cpp 2009-10-22 20:12:49.000000000 +0200
-+++ galapix-0.1.2/src/galapix/workspace.cpp 2010-01-14 17:04:41.000000000 +0100
-@@ -25,6 +25,7 @@
- #include "galapix/spiral_layouter.hpp"
- #include "galapix/tight_layouter.hpp"
- #include "util/file_reader.hpp"
-+#include <iostream>
-
- struct ImageSorter
- {
-diff -ruN galapix-0.1.2-orig/src/job/job_worker_thread.cpp galapix-0.1.2/src/job/job_worker_thread.cpp
---- galapix-0.1.2-orig/src/job/job_worker_thread.cpp 2009-10-22 14:44:38.000000000 +0200
-+++ galapix-0.1.2/src/job/job_worker_thread.cpp 2010-01-14 17:05:55.000000000 +0100
-@@ -19,6 +19,7 @@
- #include "job/job_worker_thread.hpp"
-
- #include "job/job.hpp"
-+#include <iostream>
-
- JobWorkerThread::JobWorkerThread()
- : m_queue(),
-diff -ruN galapix-0.1.2-orig/src/job/thread.cpp galapix-0.1.2/src/job/thread.cpp
---- galapix-0.1.2-orig/src/job/thread.cpp 2009-10-22 14:44:38.000000000 +0200
-+++ galapix-0.1.2/src/job/thread.cpp 2010-01-14 17:06:42.000000000 +0100
-@@ -17,6 +17,7 @@
- */
-
- #include "job/thread.hpp"
-+#include <iostream>
-
- Thread::Thread()
- : m_thread()
-diff -ruN galapix-0.1.2-orig/src/sdl/sdl_viewer.cpp galapix-0.1.2/src/sdl/sdl_viewer.cpp
---- galapix-0.1.2-orig/src/sdl/sdl_viewer.cpp 2009-10-18 16:37:30.000000000 +0200
-+++ galapix-0.1.2/src/sdl/sdl_viewer.cpp 2010-01-14 17:08:46.000000000 +0100
-@@ -33,6 +33,7 @@
- #include "sdl/sdl_framebuffer.hpp"
- #include "spnav/space_navigator.hpp"
- #include "util/filesystem.hpp"
-+#include <iostream>
-
- #ifdef HAVE_SPACE_NAVIGATOR
- # include <spnav.h>
-diff -ruN galapix-0.1.2-orig/src/tools/rotate_tool.cpp galapix-0.1.2/src/tools/rotate_tool.cpp
---- galapix-0.1.2-orig/src/tools/rotate_tool.cpp 2009-10-12 15:31:00.000000000 +0200
-+++ galapix-0.1.2/src/tools/rotate_tool.cpp 2010-01-14 17:07:25.000000000 +0100
-@@ -22,6 +22,7 @@
-
- #include "galapix/viewer.hpp"
- #include "galapix/workspace.hpp"
-+#include <iostream>
-
- RotateTool::RotateTool(Viewer* viewer_)
- : Tool(viewer_),
-diff -ruN galapix-0.1.2-orig/src/util/weak_functor.hpp galapix-0.1.2/src/util/weak_functor.hpp
---- galapix-0.1.2-orig/src/util/weak_functor.hpp 2009-10-25 02:26:51.000000000 +0200
-+++ galapix-0.1.2/src/util/weak_functor.hpp 2010-01-14 17:01:14.000000000 +0100
-@@ -20,6 +20,7 @@
- #define HEADER_GALAPIX_UTIL_WEAK_FUNCTOR_HPP
-
- #include <boost/weak_ptr.hpp>
-+#include <iostream>
-
- /**
- * WeakFunctor allows you to create functors from objects that are
diff --git a/imagemagick_plugin.patch b/imagemagick_plugin.patch
new file mode 100755
index 000000000000..c80af2237922
--- /dev/null
+++ b/imagemagick_plugin.patch
@@ -0,0 +1,30 @@
+--- src/plugins/imagemagick.cpp 2013-03-18 14:21:49.848848166 +0900
++++ src/plugins/imagemagick.cpp.new 2013-03-18 15:37:57.502107423 +0900
+@@ -124,10 +124,10 @@
+
+ for(int x = 0; x < width; ++x)
+ {
+- dst_pixels[4*x + 0] = static_cast<uint8_t>(src_pixels[x].red >> shift);
+- dst_pixels[4*x + 1] = static_cast<uint8_t>(src_pixels[x].green >> shift);
+- dst_pixels[4*x + 2] = static_cast<uint8_t>(src_pixels[x].blue >> shift);
+- dst_pixels[4*x + 3] = static_cast<uint8_t>(255 - (src_pixels[x].opacity >> shift));
++ dst_pixels[4*x + 0] = static_cast<uint8_t>(src_pixels[x].red / QuantumRange * QuantumRange);
++ dst_pixels[4*x + 1] = static_cast<uint8_t>(src_pixels[x].green / QuantumRange * QuantumRange);
++ dst_pixels[4*x + 2] = static_cast<uint8_t>(src_pixels[x].blue / QuantumRange * QuantumRange);
++ dst_pixels[4*x + 3] = static_cast<uint8_t>(255 - (src_pixels[x].opacity / QuantumRange * QuantumRange));
+ }
+ }
+ }
+@@ -142,9 +142,9 @@
+
+ for(int x = 0; x < width; ++x)
+ {
+- dst_pixels[3*x + 0] = static_cast<uint8_t>(src_pixels[x].red >> shift);
+- dst_pixels[3*x + 1] = static_cast<uint8_t>(src_pixels[x].green >> shift);
+- dst_pixels[3*x + 2] = static_cast<uint8_t>(src_pixels[x].blue >> shift);
++ dst_pixels[3*x + 0] = static_cast<uint8_t>(src_pixels[x].red / QuantumRange * QuantumRange);
++ dst_pixels[3*x + 1] = static_cast<uint8_t>(src_pixels[x].green / QuantumRange * QuantumRange);
++ dst_pixels[3*x + 2] = static_cast<uint8_t>(src_pixels[x].blue / QuantumRange * QuantumRange);
+ }
+ }
+ }
diff --git a/png_string_fix.patch b/png_string_fix.patch
new file mode 100755
index 000000000000..36d3675116b8
--- /dev/null
+++ b/png_string_fix.patch
@@ -0,0 +1,11 @@
+--- src/plugins/png.cpp 2013-10-14 21:28:34.109215677 +0900
++++ src/plugins/png.cpp.new 2013-10-14 21:33:43.261057151 +0900
+@@ -20,7 +20,7 @@
+
+ #include <png.h>
+ #include <stdexcept>
+-
++#include <string.h>
+ #include "util/log.hpp"
+
+ struct PNGReadMemory