summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhalfhorn2020-02-16 13:53:45 -0500
committerhalfhorn2020-02-16 13:53:45 -0500
commit160f9527f5664daf4eae71498173d1ab342bd682 (patch)
tree7d1bb77ee7a70a4197131f8b5165a7ddcf9e5cc1
downloadaur-160f9527f5664daf4eae71498173d1ab342bd682.tar.gz
initial upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
-rw-r--r--galaxia.install4
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c63e50de2a05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = galaxia
+ pkgdesc = code written in C++ to generate a synthetic survey of the Milky Way
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = http://galaxia.sourceforge.net/
+ install = galaxia.install
+ arch = any
+ license = GPL3
+ depends = gcc-libs
+ source = https://phoenixnap.dl.sourceforge.net/project/galaxia/galaxia-0.7.2.tar.gz
+ md5sums = 0f1dec3a69bde5231f7082787ef99d30
+
+pkgname = galaxia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff4ba10840ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Wells (halfhorn) com dot gmail at mwellsa
+pkgname=galaxia
+pkgver=0.7.2
+pkgrel=1
+epoch=
+pkgdesc="code written in C++ to generate a synthetic survey of the Milky Way"
+arch=('any')
+url="http://galaxia.sourceforge.net/"
+license=('GPL3')
+groups=()
+depends=('gcc-libs')
+install="$pkgname.install"
+source=("https://phoenixnap.dl.sourceforge.net/project/galaxia/galaxia-0.7.2.tar.gz")
+md5sums=('0f1dec3a69bde5231f7082787ef99d30')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix="/usr" --datadir="/usr/share/galaxia"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ mkdir -p "$pkgdir/usr/share"
+ mv GalaxiaData "$pkgdir/usr/share/galaxia"
+}
diff --git a/galaxia.install b/galaxia.install
new file mode 100644
index 000000000000..95d6245e8ac8
--- /dev/null
+++ b/galaxia.install
@@ -0,0 +1,4 @@
+post_install() {
+ printf "generating BHTree files for disc with warp\n"
+ galaxia -s warp
+}