summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchris-marsh2017-01-29 11:28:15 +0000
committerchris-marsh2017-01-29 11:28:15 +0000
commit97c27dbd9dbbed7ba65d09eee939f6f4f469cce1 (patch)
tree7205c0d02b7fc4650ab54e65ab085932f4e3febf
downloadaur-97c27dbd9dbbed7ba65d09eee939f6f4f469cce1.tar.gz
First commit of Galendae calendar to the AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c15d05f51245
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = galendae-git
+ pkgdesc = A basic popup calendar that can be styled to match workspace themes
+ pkgver = r24.df3c4b0
+ pkgrel = 1
+ url = https://github.com/chris-marsh/galendae
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = gtk3
+ source = git+https://github.com/chris-marsh/galendae.git
+ md5sums = SKIP
+
+pkgname = galendae-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25997508a584
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Chris Marsh <chris.pm@gmail.com>
+
+pkgname=galendae-git
+pkgver=r24.df3c4b0
+pkgrel=1
+pkgdesc="A basic popup calendar that can be styled to match workspace themes"
+arch=('i686' 'x86_64')
+url="https://github.com/chris-marsh/galendae"
+license=('MIT')
+depends=('gtk3')
+makedepends=('git')
+source=("git+https://github.com/chris-marsh/galendae.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname%-git}
+ make release
+}
+
+package() {
+ cd ${pkgname%-git}
+ install -d "$pkgdir"/usr/{bin,share/galendae/examples}
+ install -m755 galendae "$pkgdir"/usr/bin/
+ install -m644 examples/* "$pkgdir"/usr/share/galendae/examples/
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}