summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Garnica2020-09-19 10:56:14 +0200
committerSergio Garnica2020-09-19 10:56:14 +0200
commite90a133498a6b5e9845dca12caf526758152d98a (patch)
treef25ef75f91359307207c6dfac4fe7e00b6e2a7c8
parent86d14760e3e5666cc8d385c05ce495edc021a53b (diff)
downloadaur-e90a133498a6b5e9845dca12caf526758152d98a.tar.gz
Change upstream to github
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1796df309a5d..3de5beeda335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Wed May 16 15:48:42 UTC 2018
pkgbase = galileo-dev
pkgdesc = Utility to securely synchronize a Fitbit tracker with the Fitbit server. Development version, which supports synchronization without dongle, through bluetooth (experimental)
- pkgver = 1.0dev
- pkgrel = 3
- url = https://bitbucket.org/benallard/galileo
+ pkgver = 0.5.1.r125.g42efa16
+ pkgrel = 1
+ url = https://github.com/benallard/galileo
install = galileo.install
arch = any
license = LGPL3
- makedepends = mercurial
+ makedepends = git
makedepends = python-setuptools
depends = python-pyusb
depends = python-requests
@@ -16,7 +14,7 @@ pkgbase = galileo-dev
conflicts = galileo
options = !emptydirs
backup = etc/galileo/config
- source = galileo-dev::hg+https://bitbucket.org/benallard/galileo/src#branch=default
+ source = galileo-dev::git+https://github.com/benallard/galileo.git
md5sums = SKIP
pkgname = galileo-dev
diff --git a/PKGBUILD b/PKGBUILD
index 769f89585a13..c20c5508fb50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,31 @@
# Contributor: Étienne Deparis <etienne [at] depar.is>
pkgname=galileo-dev
-pkgver=1.0dev
-pkgrel=3
+pkgver=0.5.1.r125.g42efa16
+pkgrel=1
pkgdesc='Utility to securely synchronize a Fitbit tracker with the Fitbit server. Development version, which supports synchronization without dongle, through bluetooth (experimental)'
license=('LGPL3')
-url='https://bitbucket.org/benallard/galileo'
+url='https://github.com/benallard/galileo'
depends=('python-pyusb' 'python-requests' 'python-pydbus')
-makedepends=('mercurial' 'python-setuptools')
+makedepends=('git' 'python-setuptools')
conflicts=('galileo')
-source=("$pkgname::hg+https://bitbucket.org/benallard/galileo/src#branch=default")
+source=("$pkgname::git+https://github.com/benallard/galileo.git")
md5sums=('SKIP')
arch=('any')
options=(!emptydirs)
backup=("etc/galileo/config")
install=galileo.install
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd $srcdir/$pkgname
sed -i 's/logging: verbose/logging: quiet # quiet is default/' galileorc.sample
sed -i "26,35s/^\(.*\)$/\#\1/" galileorc.sample
-
sed -i "s|/etc/galileorc|/etc/galileo/config|" contrib/galileo.service
}