summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlll2yu2018-03-29 23:05:14 +0530
committerlll2yu2018-03-29 23:05:14 +0530
commit22f1b78b2e324a80c52f78082a118824b709c1f4 (patch)
tree3c878a0beb0fbaf4183727d4740f719f11ab0805
downloadaur-22f1b78b2e324a80c52f78082a118824b709c1f4.tar.gz
Initial release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b74e96093be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gallery-dl
+ pkgdesc = Command-line program to download image galleries and collections from pixiv, exhentai, danbooru and more
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/mikf/gallery-dl
+ arch = any
+ license = GPL2
+ depends = python
+ source = https://github.com/mikf/gallery-dl/archive/v1.3.2.tar.gz
+ sha256sums = 19d2ec29762ab9b8e2d1fa6b2804ffc880578366ab9a1a8f7573961ba3a22be7
+
+pkgname = gallery-dl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f91dbb576c74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: LLL2yu <lll2yu@protonmail.com>
+
+pkgname=gallery-dl
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Command-line program to download image galleries and collections from pixiv, exhentai, danbooru and more"
+arch=('any')
+url="https://github.com/mikf/gallery-dl"
+license=("GPL2")
+depends=('python')
+source=(https://github.com/mikf/${pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('19d2ec29762ab9b8e2d1fa6b2804ffc880578366ab9a1a8f7573961ba3a22be7')
+
+package() {
+ cd "$srcdir"/${pkgname}-$pkgver
+ python setup.py install -O1 --root="$pkgdir"
+}