summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author=2021-06-10 08:59:26 -0700
committer=2021-06-10 08:59:26 -0700
commita9d5631d86847e64b4777961d22d38396be0d5dc (patch)
tree3727dcb7da6ba0b637174a38769127397e6dc9cc
downloadaur-a9d5631d86847e64b4777961d22d38396be0d5dc.tar.gz
initial commit for the binary release of gallery-dl
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD33
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea4fac7c5bd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gallery-dl-bin
+ pkgdesc = Command-line program to download image-galleries and collections from several image hosting sites
+ pkgver = 1.17.5
+ pkgrel = 1
+ url = https://github.com/mikf/gallery-dl
+ arch = x86_64
+ license = GPL2
+ depends = zlib
+ provides = gallery-dl
+ source = https://github.com/mikf/gallery-dl/releases/download/v1.17.5/gallery-dl.bin
+ source = https://github.com/mikf/gallery-dl/releases/download/v1.17.5/gallery-dl.bin.sig
+ source = https://api.github.com/repos/mikf/gallery-dl/releases/latest
+ validpgpkeys = 3E09F5908333DD83DBDCE7375680CA389D365A88
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gallery-dl-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c743e1c98daa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/*
+pkg/*
+*.zst
+*.sig
+*.bin
+latest
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2cde12a8460
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: samarthj <dev@samarthj.com>
+# Packaging binary release from creator's release assests
+# Building via python has an issue with cloudflare due to a urllib3 dependency
+# https://github.com/mikf/gallery-dl/issues/1117
+# This binary release pushes this burden of dependency version resolution to the creator
+
+pkgname=gallery-dl-bin
+pkgver=1.17.5
+pkgrel=1
+url='https://github.com/mikf/gallery-dl'
+pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites (bin)'
+arch=('x86_64')
+depends=('zlib')
+provides=('gallery-dl')
+conflicts=('gallery-dl' 'gallery-dl-git')
+license=(GPL2)
+source=("${url}"/releases/download/v"${pkgver}"/gallery-dl.bin{,.sig}
+ https://api.github.com/repos/mikf/gallery-dl/releases/latest)
+validpgpkeys=('3E09F5908333DD83DBDCE7375680CA389D365A88')
+sha256sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "${srcdir}"
+ chmod +x gallery-dl.bin
+ grep -oP 'https://.*gallery-dl.bin' latest |
+ head -n1 |
+ sed -re 's|.*/v(.*)/gallery-dl.bin|\1|g'
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm0775 gallery-dl.bin "${pkgdir}"/usr/bin/gallery-dl
+}