summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2021-03-10 19:59:52 +0100
committerMagnus Boman2021-03-10 19:59:52 +0100
commit1c10f04289d536f80903acfb42d0854bfec8decf (patch)
tree27ab53f02dd798274c498699050d6d391a425111
parentabe16268893243b8d03618c7657e451b9849918f (diff)
downloadaur-1c10f04289d536f80903acfb42d0854bfec8decf.tar.gz
upgpkg: gallery-dl-git 1.17.0.r9.g780bac4c-1
conform to packaging guidelines
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca79eda75ca7..b0bbdc12e72b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gallery-dl-git
- pkgdesc = Command-line program to download image-galleries and collections from several image hosting sites
- pkgver = 1.14.2.r14.g27d163af
+ pkgdesc = Command-line program to download image-galleries and collections from several image hosting sites (git)
+ pkgver = 1.17.0.r9.g780bac4c
pkgrel = 1
url = https://github.com/mikf/gallery-dl
arch = any
@@ -17,4 +17,3 @@ pkgbase = gallery-dl-git
md5sums = SKIP
pkgname = gallery-dl-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 49ee11d10d0d..c1d31f1d5916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: katt <magunasu.b97@gmail.com>
pkgname=gallery-dl-git
-pkgver=1.14.2.r14.g27d163af
+pkgver=1.17.0.r9.g780bac4c
pkgrel=1
-pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites'
-arch=('any')
-url='https://github.com/mikf/gallery-dl'
-license=('GPL2')
-depends=('python' 'python-requests')
-makedepends=('python-setuptools' 'git')
+pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites (git)'
+arch=(any)
+url=https://github.com/mikf/gallery-dl
+license=(GPL2)
+depends=(python python-requests)
+makedepends=(python-setuptools git)
optdepends=('ffmpeg: Convert Pixiv Ugoira to WebM'
'youtube-dl: Download videos')
provides=("${pkgname%-git}")
@@ -17,16 +17,16 @@ source=(git+"${url}".git)
md5sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "${pkgname%-git}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${pkgname%-git}"
make
+ python setup.py build
}
package() {
cd "${pkgname%-git}"
- python setup.py install -O1 --root="$pkgdir"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}