summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2019-11-01 00:30:52 +0100
committerMagnus Boman2019-11-01 00:30:52 +0100
commitde468fd293d00304471f4ae2e5b269e3e9066c99 (patch)
treef6ebe6ee4fd3f1608cb700eb46ab1762c050b965
parent2460eca8e575e928844e96c700f9f2dbc1fa8b29 (diff)
downloadaur-de468fd293d00304471f4ae2e5b269e3e9066c99.tar.gz
changed pkgver scheme
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index feaf7bb62e10..4919a1769f7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: katt <magunasu.b97 [at] gmail [dot] com>
_pkgname=gallery-dl
-pkgname=gallery-dl-git
-pkgver=r1885.b1728f5
+pkgname=$_pkgname-git
+pkgver=1.10.6.r37.g8361d87
pkgrel=1
pkgdesc="Command-line program to download image-galleries and collections from several image hosting sites"
arch=('any')
@@ -14,12 +14,12 @@ optdepends=('ffmpeg: Convert Pixiv Ugoira to WebM'
'youtube-dl: Download videos')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=(git+https://github.com/mikf/$_pkgname.git)
+source=(git+https://github.com/mikf/gallery-dl.git)
sha512sums=('SKIP')
pkgver() {
cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){