summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarrell Enns2015-07-05 13:50:42 -0700
committerDarrell Enns2015-07-05 13:50:42 -0700
commite6a4a8bc9f5f6dc49a5554aa73353c2e56295d36 (patch)
tree29827697ff50c64d42962c688daae9aabc5384c9
downloadaur-e6a4a8bc9f5f6dc49a5554aa73353c2e56295d36.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--gallery2.install5
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2450c5a83e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gallery2
+ pkgdesc = Open source web based photo album organizer.
+ pkgver = 2.3.2
+ pkgrel = 1
+ url = http://galleryproject.org/
+ install = gallery2.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = php
+ depends = mariadb
+ source = http://downloads.sourceforge.net/gallery/gallery-2.3.2-full.zip
+ sha512sums = 601b67822e633214258484ed87ca4d088babe3d04895f192fcbed94733eef93509d651cdc17fe670705100ba17435daa772f1aaee4965627ed583789afaae6f7
+
+pkgname = gallery2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef3f274ae01e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Darrell Enns <darrell@darrellenns.com>
+
+# Todo: chown/chgrp http webapps dir
+
+pkgname=gallery2
+pkgver=2.3.2
+pkgrel=1
+pkgdesc="Open source web based photo album organizer."
+arch=('i686' 'x86_64')
+url="http://galleryproject.org/"
+license=('GPL')
+depends=('php' 'mariadb')
+source=(http://downloads.sourceforge.net/gallery/gallery-$pkgver-full.zip)
+sha512sums=('601b67822e633214258484ed87ca4d088babe3d04895f192fcbed94733eef93509d651cdc17fe670705100ba17435daa772f1aaee4965627ed583789afaae6f7')
+
+install=$pkgname.install
+
+package() {
+ mkdir -p "$pkgdir/usr/share/webapps"
+ cp -a "$srcdir/gallery2" "$pkgdir/usr/share/webapps/"
+}
diff --git a/gallery2.install b/gallery2.install
new file mode 100644
index 000000000000..cfc721ee892b
--- /dev/null
+++ b/gallery2.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo -e "Please see the documentation at http://codex.gallery2.org/"
+ echo -e "for installation and configuration details."
+}
+