summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Stryker2019-01-23 12:57:08 -0500
committerJason Stryker2019-01-23 12:57:08 -0500
commit0e2939205dc200d77c80b2dd1dba4d1f5a862bc1 (patch)
treebcfbd01cfa40076ecfa7fd10d4fe550c7c6d8974
downloadaur-0e2939205dc200d77c80b2dd1dba4d1f5a862bc1.tar.gz
create package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD76
2 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86e749f1ef87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gallium-nine
+ pkgdesc = Gallium Nine Standalone
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/dhewg/nine
+ arch = x86_64
+ license = LGPL2
+ makedepends = git
+ makedepends = wine
+ makedepends = mesa
+ makedepends = meson
+ source = https://github.com/dhewg/nine/archive/v0.1.tar.gz
+ sha512sums = c1ef8d1cb7f35802f92012fd18258cd59c0218f78d7bf43bf0073cc47a51f99e8649177b163a85b4bcdf6379ca96db09249df90a5f13f0371814e6d18ee36a9b
+
+pkgname = gallium-nine
+ depends = mesa
+ provides = gallium-nine
+
+pkgname = lib32-gallium-nine
+ depends = gallium-nine
+ depends = lib32-mesa
+ provides = lib32-gallium-nine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..243ad5c5c1d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Jason Stryker <inbox at jasonstryker dot com>
+
+pkgbase=gallium-nine
+pkgname=('gallium-nine' 'lib32-gallium-nine')
+pkgver=0.1
+pkgrel=1
+pkgdesc="Gallium Nine Standalone"
+arch=('x86_64')
+url="https://github.com/dhewg/nine"
+license=('LGPL2')
+makedepends=('git' 'wine' 'mesa' 'meson')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('c1ef8d1cb7f35802f92012fd18258cd59c0218f78d7bf43bf0073cc47a51f99e8649177b163a85b4bcdf6379ca96db09249df90a5f13f0371814e6d18ee36a9b')
+
+build() {
+ cd ${srcdir}/nine-${pkgver}
+
+ sed -i "s#^BASE=.*#BASE=/usr/share/nine#g" "tools/nine-install.sh"
+
+ sed "s/@PKG_CONFIG@/i686-pc-linux-gnu-pkg-config/" \
+ < tools/cross-wine32.in \
+ > tools/cross-wine32
+
+ sed "s/@PKG_CONFIG@/x86_64-pc-linux-gnu-pkg-config/" \
+ < tools/cross-wine64.in \
+ > tools/cross-wine64
+
+ meson \
+ --cross-file "tools/cross-wine64" \
+ --buildtype "release" \
+ --prefix "/usr/share/nine" \
+ --bindir bin64 \
+ --libdir lib64 \
+ "build64"
+
+ ninja -C "build64"
+
+ meson \
+ --cross-file "tools/cross-wine32" \
+ --buildtype "release" \
+ --prefix "/usr/share/nine" \
+ --bindir bin32 \
+ --libdir lib32 \
+ "build32"
+
+ ninja -C "build32"
+
+}
+
+_package_gallium-nine() {
+
+ cd ${srcdir}/nine-${pkgver}
+
+ DESTDIR="$pkgdir" ninja -C "build$1" install
+
+}
+
+package_gallium-nine() {
+ provides=("gallium-nine")
+ depends=('mesa')
+
+ _package_gallium-nine 64
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm 0755 "tools/nine-install.sh" "${pkgdir}/usr/bin/"
+
+}
+
+package_lib32-gallium-nine() {
+ provides=("lib32-gallium-nine")
+ depends=('gallium-nine' 'lib32-mesa')
+
+ _package_gallium-nine 32
+
+}
+# vim:set ts=2 sw=2 et: