summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-02-06 21:25:52 +0100
committerMichael Straube2016-02-06 21:25:52 +0100
commit3280d3292d00eca52481fed284775f317ff507ad (patch)
tree9ed14d2944b392854e4f2e369a277f4522a947fe
parent147ad3e4843d608f315a4ec2485c5df760e3e796 (diff)
downloadaur-3280d3292d00eca52481fed284775f317ff507ad.tar.gz
Fix build error (C++11), fix install path
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
-rw-r--r--fix-install-path.patch28
3 files changed, 50 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb2b1ce812f5..b70368a1c810 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 20:22:54 UTC 2016
pkgbase = galois
pkgdesc = A computer game of the "falling blocks" type, but with unique features
pkgver = 0.4
- pkgrel = 2
+ pkgrel = 3
url = http://www.nongnu.org/galois/
arch = i686
arch = x86_64
@@ -9,7 +11,9 @@ pkgbase = galois
depends = gtkmm
depends = libxml++
source = http://download.savannah.gnu.org/releases/galois/source/galois-0.4.tar.gz
+ source = fix-install-path.patch
md5sums = dc80a8cac1aee42a66b7f992ac593bf5
+ md5sums = 5d888b0110fa18f1dcbc62da1286e6b8
pkgname = galois
diff --git a/PKGBUILD b/PKGBUILD
index ab63c0d597d2..05bb2e184425 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
-# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: Michael Straube <m.s.online gmx.de>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: kusakata <shohei atmark kusakata period com>
pkgname=galois
pkgver=0.4
-pkgrel=2
+pkgrel=3
pkgdesc='A computer game of the "falling blocks" type, but with unique features'
arch=('i686' 'x86_64')
url="http://www.nongnu.org/galois/"
license=('GPL3')
depends=('gtkmm' 'libxml++')
-source=("http://download.savannah.gnu.org/releases/galois/source/galois-${pkgver}.tar.gz")
-md5sums=('dc80a8cac1aee42a66b7f992ac593bf5')
+source=("http://download.savannah.gnu.org/releases/galois/source/galois-${pkgver}.tar.gz"
+ "fix-install-path.patch")
+md5sums=('dc80a8cac1aee42a66b7f992ac593bf5'
+ '5d888b0110fa18f1dcbc62da1286e6b8')
+
+prepare() {
+ cd "${srcdir}"
+ patch -p0 < fix-install-path.patch
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr CXX="g++ -std=c++11"
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
}
-
-
diff --git a/fix-install-path.patch b/fix-install-path.patch
new file mode 100644
index 000000000000..0f3e2c2dcd9a
--- /dev/null
+++ b/fix-install-path.patch
@@ -0,0 +1,28 @@
+--- galois-0.4/src/makefile.in.orig 2016-02-06 20:53:18.701336710 +0100
++++ galois-0.4/src/makefile.in 2016-02-06 20:53:41.444173725 +0100
+@@ -50,10 +50,10 @@
+ - rm -f ${AC}
+
+ install : galois
+- mkdir -p ${prefix}/games
+- cp galois ${prefix}/games
++ mkdir -p ${prefix}/bin
++ cp galois ${prefix}/bin
+ uninstall :
+- - rm -f ${prefix}/games/galois
++ - rm -f ${prefix}/bin/galois
+
+ # dependencies
+ area.o : area.h grid.h group.h
+
+--- galois-0.4/misc/galois.desktop.in.orig 2016-02-06 20:52:37.265574946 +0100
++++ galois-0.4/misc/galois.desktop.in 2016-02-06 20:52:49.085316730 +0100
+@@ -17,7 +17,7 @@
+ # @configure_input@
+
+ [Desktop Entry]
+-Exec=@prefix@/games/galois
++Exec=@prefix@/bin/galois
+ Terminal=false
+ Type=Application
+ Categories=GNOME;GTK;Game;BlocksGame;