summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2019-09-15 10:33:15 +0200
committerMichael Straube2019-09-15 10:33:15 +0200
commitb847e83f7729ce8443f09be872b37478e0c8c4be (patch)
tree1ba0f01ed5ed0fcae6ad3f19b15d097e4e3e0244
parent0a544b56601ffe7744dfb552408b8224acf2d7b8 (diff)
downloadaur-b847e83f7729ce8443f09be872b37478e0c8c4be.tar.gz
Update to 0.6
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--galois-0.6-full-relro.patch11
-rw-r--r--galois-0.6-install-path.patch (renamed from galois-0.5-install-path.patch)0
-rw-r--r--galois-0.6-libxml++3.0.patch (renamed from galois-0.5-libxml++3.0.patch)42
5 files changed, 55 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad3789471ef7..ac137992b536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = galois
- pkgdesc = A computer game of the "falling blocks" type, but with unique features
- pkgver = 0.5
+ pkgdesc = A falling blocks game with blocks of various shapes and sizes
+ pkgver = 0.6
pkgrel = 1
url = http://www.nongnu.org/galois
- arch = i686
arch = x86_64
license = GPL3
depends = gtkmm3
depends = libxml++
- source = https://download.savannah.gnu.org/releases/galois/source/galois-0.5.tar.gz
- source = galois-0.5-install-path.patch
- source = galois-0.5-libxml++3.0.patch
- sha256sums = 94eecd9f1038df5fd19b14ca5b2634bd00d0cd9c534a50a996558d8ac29fb394
+ source = https://download.savannah.gnu.org/releases/galois/source/galois-0.6.tar.gz
+ source = galois-0.6-install-path.patch
+ source = galois-0.6-full-relro.patch
+ source = galois-0.6-libxml++3.0.patch
+ sha256sums = de4743c9407afb33a186cd3a3cbf472d790901c41a009bd1775dcf59b466b346
sha256sums = c4247271776f7b5df2b6bb92911c25a9ba3c30796171de5cd7dc1bd78e5a800d
- sha256sums = 3d5302c362cadfb1e350153e373dfce9bfbefaf83fc3427069ce0cc071f84b86
+ sha256sums = 24c833ad3f898968938bf39768093f257e8badfb84058ada6c6f36df2e7c554d
+ sha256sums = 1bce72dfb66dcaa06e7c76c506c97595d9528914d6e4bd47beb8f2cfdaa97e3c
pkgname = galois
diff --git a/PKGBUILD b/PKGBUILD
index 33211641d8a2..9a81a9a3d680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
# Maintainer:
+# Contributor: Michael Straube <michael.straube@posteo.de>
# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: kusakata <shohei atmark kusakata period com>
pkgname=galois
-pkgver=0.5
+pkgver=0.6
pkgrel=1
-pkgdesc='A computer game of the "falling blocks" type, but with unique features'
-arch=('i686' 'x86_64')
+pkgdesc='A falling blocks game with blocks of various shapes and sizes'
+arch=('x86_64')
url="http://www.nongnu.org/galois"
license=('GPL3')
depends=('gtkmm3' 'libxml++')
source=("https://download.savannah.gnu.org/releases/galois/source/galois-$pkgver.tar.gz"
- "galois-0.5-install-path.patch"
- "galois-0.5-libxml++3.0.patch")
-sha256sums=('94eecd9f1038df5fd19b14ca5b2634bd00d0cd9c534a50a996558d8ac29fb394'
+ "galois-0.6-install-path.patch"
+ "galois-0.6-full-relro.patch"
+ "galois-0.6-libxml++3.0.patch")
+
+sha256sums=('de4743c9407afb33a186cd3a3cbf472d790901c41a009bd1775dcf59b466b346'
'c4247271776f7b5df2b6bb92911c25a9ba3c30796171de5cd7dc1bd78e5a800d'
- '3d5302c362cadfb1e350153e373dfce9bfbefaf83fc3427069ce0cc071f84b86')
+ '24c833ad3f898968938bf39768093f257e8badfb84058ada6c6f36df2e7c554d'
+ '1bce72dfb66dcaa06e7c76c506c97595d9528914d6e4bd47beb8f2cfdaa97e3c')
prepare() {
cd $pkgname-$pkgver
- patch -p1 -i ../galois-0.5-install-path.patch
- patch -p1 -i ../galois-0.5-libxml++3.0.patch
+ patch -p1 -i ../galois-0.6-install-path.patch
+ patch -p1 -i ../galois-0.6-full-relro.patch
+ patch -p1 -i ../galois-0.6-libxml++3.0.patch
}
build() {
diff --git a/galois-0.6-full-relro.patch b/galois-0.6-full-relro.patch
new file mode 100644
index 000000000000..7d4c27f2bd28
--- /dev/null
+++ b/galois-0.6-full-relro.patch
@@ -0,0 +1,11 @@
+--- galois-0.6/src/makefile.in.orig 2019-09-15 09:49:53.260122196 +0200
++++ galois-0.6/src/makefile.in 2019-09-15 09:50:17.580404164 +0200
+@@ -41,7 +41,7 @@
+ default: galois
+ all : ${EXE}
+ galois : ${OBJS}
+- ${CXX} ${CXXFLAGS} ${OBJS} -o $@ ${GTKMM_LIBS} ${XMLPP_LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} ${OBJS} -o $@ ${GTKMM_LIBS} ${XMLPP_LIBS}
+
+ # other targets
+ clean :
diff --git a/galois-0.5-install-path.patch b/galois-0.6-install-path.patch
index 0f3e2c2dcd9a..0f3e2c2dcd9a 100644
--- a/galois-0.5-install-path.patch
+++ b/galois-0.6-install-path.patch
diff --git a/galois-0.5-libxml++3.0.patch b/galois-0.6-libxml++3.0.patch
index 4abc54090386..f6c6953ac33f 100644
--- a/galois-0.5-libxml++3.0.patch
+++ b/galois-0.6-libxml++3.0.patch
@@ -1,6 +1,6 @@
-diff -ru galois-0.5-orig/configure galois-0.5/configure
---- galois-0.5-orig/configure 2017-12-21 17:35:20.778204557 +0100
-+++ galois-0.5/configure 2017-12-21 17:46:16.889355223 +0100
+diff -ru galois-0.6-orig/configure galois-0.6/configure
+--- galois-0.6-orig/configure 2019-09-15 10:22:36.593016489 +0200
++++ galois-0.6/configure 2019-09-15 10:22:53.446550978 +0200
@@ -2495,12 +2495,12 @@
pkg_cv_libxmlplusplus_CFLAGS="$libxmlplusplus_CFLAGS"
elif test -n "$PKG_CONFIG"; then
@@ -51,9 +51,9 @@ diff -ru galois-0.5-orig/configure galois-0.5/configure
$libxmlplusplus_PKG_ERRORS
-diff -ru galois-0.5-orig/configure.ac galois-0.5/configure.ac
---- galois-0.5-orig/configure.ac 2017-12-21 17:35:20.778204557 +0100
-+++ galois-0.5/configure.ac 2017-12-21 17:46:16.889355223 +0100
+diff -ru galois-0.6-orig/configure.ac galois-0.6/configure.ac
+--- galois-0.6-orig/configure.ac 2019-09-15 10:22:36.593016489 +0200
++++ galois-0.6/configure.ac 2019-09-15 10:22:53.446550978 +0200
@@ -21,5 +21,5 @@
AC_CONFIG_FILES([misc/galois.desktop])
AC_PROG_CXX
@@ -61,9 +61,9 @@ diff -ru galois-0.5-orig/configure.ac galois-0.5/configure.ac
-PKG_CHECK_MODULES([libxmlplusplus], [libxml++-2.6])
+PKG_CHECK_MODULES([libxmlplusplus], [libxml++-3.0])
AC_OUTPUT
-diff -ru galois-0.5-orig/src/makefile.in galois-0.5/src/makefile.in
---- galois-0.5-orig/src/makefile.in 2017-12-21 17:35:20.774871284 +0100
-+++ galois-0.5/src/makefile.in 2017-12-21 17:46:16.889355223 +0100
+diff -ru galois-0.6-orig/src/makefile.in galois-0.6/src/makefile.in
+--- galois-0.6-orig/src/makefile.in 2019-09-15 10:22:36.589683116 +0200
++++ galois-0.6/src/makefile.in 2019-09-15 10:22:53.446550978 +0200
@@ -23,8 +23,8 @@
PKG_CONFIG = @PKG_CONFIG@
GTKMM_CFLAGS = `${PKG_CONFIG} --cflags gtkmm-3.0`
@@ -75,10 +75,10 @@ diff -ru galois-0.5-orig/src/makefile.in galois-0.5/src/makefile.in
EXE = galois
AC = makefile
-diff -ru galois-0.5-orig/src/preferences.cc galois-0.5/src/preferences.cc
---- galois-0.5-orig/src/preferences.cc 2017-12-21 17:35:20.778204557 +0100
-+++ galois-0.5/src/preferences.cc 2017-12-21 17:49:38.005564783 +0100
-@@ -383,12 +383,12 @@
+diff -ru galois-0.6-orig/src/preferences.cc galois-0.6/src/preferences.cc
+--- galois-0.6-orig/src/preferences.cc 2019-09-15 10:22:36.593016489 +0200
++++ galois-0.6/src/preferences.cc 2019-09-15 10:22:53.446550978 +0200
+@@ -388,12 +388,12 @@
reader->read();
// skip whitespace and comments
while (reader->get_node_type() ==
@@ -94,7 +94,7 @@ diff -ru galois-0.5-orig/src/preferences.cc galois-0.5/src/preferences.cc
reader->get_name() != "galois_config")
return false;
-@@ -398,16 +398,16 @@
+@@ -403,16 +403,16 @@
reader->read();
// skip whitespace and comments
while (reader->get_node_type() ==
@@ -115,7 +115,7 @@ diff -ru galois-0.5-orig/src/preferences.cc galois-0.5/src/preferences.cc
return false;
// read and apply properties
-@@ -420,17 +420,17 @@
+@@ -425,17 +425,17 @@
reader->read();
// skip whitespace and comments
while (reader->get_node_type() ==
@@ -137,7 +137,7 @@ diff -ru galois-0.5-orig/src/preferences.cc galois-0.5/src/preferences.cc
reader->get_name() != "control_key")
return false;
-@@ -456,17 +456,17 @@
+@@ -461,17 +461,17 @@
reader->read();
// skip whitespace and comments
while (reader->get_node_type() ==
@@ -159,10 +159,10 @@ diff -ru galois-0.5-orig/src/preferences.cc galois-0.5/src/preferences.cc
reader->get_name() != "control_key")
return false;
-diff -ru galois-0.5-orig/src/scores.cc galois-0.5/src/scores.cc
---- galois-0.5-orig/src/scores.cc 2017-12-21 17:35:20.774871284 +0100
-+++ galois-0.5/src/scores.cc 2017-12-21 17:51:00.384008315 +0100
-@@ -414,12 +414,12 @@
+diff -ru galois-0.6-orig/src/scores.cc galois-0.6/src/scores.cc
+--- galois-0.6-orig/src/scores.cc 2019-09-15 10:22:36.593016489 +0200
++++ galois-0.6/src/scores.cc 2019-09-15 10:22:53.446550978 +0200
+@@ -420,12 +420,12 @@
reader->read();
// skip whitespace and comments
while (reader->get_node_type() ==
@@ -178,7 +178,7 @@ diff -ru galois-0.5-orig/src/scores.cc galois-0.5/src/scores.cc
reader->get_name() != "galois_scores")
return false;
-@@ -430,16 +430,16 @@
+@@ -436,16 +436,16 @@
reader->read();
// skip whitespace and comments
while (reader->get_node_type() ==