summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-08-13 09:43:31 -0600
committerAinola2018-08-13 09:43:31 -0600
commit716362ed0ee788b6ed4794832ad04dc8f1d310d0 (patch)
tree7702e97935fe92d56f6d0ea09788556d831575de
parentde287be24a0ef8b03951de2fac637f1df4888188 (diff)
downloadaur-716362ed0ee788b6ed4794832ad04dc8f1d310d0.tar.gz
commited a bad patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--xdg_config_dirs.patch51
3 files changed, 41 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50a0fa32e69d..8f7cd970f1aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Aug 12 02:27:56 UTC 2018
+# Mon Aug 13 15:43:21 UTC 2018
pkgbase = gam
pkgdesc = Command line tool for Google G Suite Administrators to manage domain and user settings quickly and easily.
pkgver = 4.60
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jay0lee/GAM
arch = any
license = Apache
@@ -19,7 +19,7 @@ pkgbase = gam
source = xdg_config_dirs.patch
source = gam.sh
sha256sums = f8274b2aff987a41344bb3ddcd6f43cbda27d5fc8de830a5f961764662cee959
- sha256sums = e85568f0f0e038e01c88a5b2b4e30f057faf737f6e8dac1c41463ec20825118a
+ sha256sums = 2879cbdcde779fa9cc6bafeadf657369377e5c317e9564c5e144c29ba9daa383
sha256sums = d93809852ef9eefeb99f3fc1b955305264f93f2552db14b4d9d6fe7c2b08345b
pkgname = gam
diff --git a/PKGBUILD b/PKGBUILD
index 85a9754fcae5..fff68e353a5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gam
pkgver=4.60
-pkgrel=1
+pkgrel=2
pkgdesc="Command line tool for Google G Suite Administrators to manage domain and user settings quickly and easily."
arch=('any')
url="https://github.com/jay0lee/GAM"
@@ -24,7 +24,7 @@ source=(
"gam.sh"
)
sha256sums=('f8274b2aff987a41344bb3ddcd6f43cbda27d5fc8de830a5f961764662cee959'
- 'e85568f0f0e038e01c88a5b2b4e30f057faf737f6e8dac1c41463ec20825118a'
+ '2879cbdcde779fa9cc6bafeadf657369377e5c317e9564c5e144c29ba9daa383'
'd93809852ef9eefeb99f3fc1b955305264f93f2552db14b4d9d6fe7c2b08345b')
prepare() {
diff --git a/xdg_config_dirs.patch b/xdg_config_dirs.patch
index e799bf715220..d1e2ef5a82b8 100644
--- a/xdg_config_dirs.patch
+++ b/xdg_config_dirs.patch
@@ -1,21 +1,42 @@
---- src/var.py 2018-08-10 23:05:08.294626452 -0600
+--- src/var.py 2018-08-03 14:30:31.000000000 -0600
+++ src/var.py 2018-08-11 12:02:27.184546770 -0600
-@@ -23,11 +23,11 @@
- try:
- XDG_CONFIG_DIR = os.environ['XDG_CONFIG_HOME']
- except KeyError:
-- XDG_CONFIG_DIR = unicode(os.path.expanduser("~") + '/.config/')
--CONFIG_DIR = XDG_CONFIG_DIR + 'gam/'
+@@ -20,6 +20,18 @@
+ GAM_LATEST_RELEASE = GAM_ALL_RELEASES+u'/latest'
+ GAM_PROJECT_APIS = u'https://raw.githubusercontent.com/jay0lee/GAM/master/src/project-apis.txt'
+
++try:
++ XDG_CONFIG_DIR = os.environ['XDG_CONFIG_HOME']
++except KeyError:
+ XDG_CONFIG_DIR = os.path.expanduser("~") + '/.config/'
+CONFIG_DIR = unicode(XDG_CONFIG_DIR) + u'gam/'
-
- try:
-- os.makedirs(CONFIG_DIR)
++
++try:
+ os.makedirs(CONFIG_DIR, mode=0700)
- except OSError:
- if not os.path.isdir(CONFIG_DIR):
- raise
-@@ -665,7 +665,7 @@
++except OSError:
++ if not os.path.isdir(CONFIG_DIR):
++ raise
++
+ TRUE = u'true'
+ FALSE = u'false'
+ true_values = [u'on', u'yes', u'enabled', u'true', u'1']
+@@ -36,11 +48,11 @@
+ ONE_KILO_BYTES = 1000
+ ONE_MEGA_BYTES = 1000000
+ ONE_GIGA_BYTES = 1000000000
+-FN_CLIENT_SECRETS_JSON = u'client_secrets.json'
+-FN_EXTRA_ARGS_TXT = u'extra-args.txt'
+-FN_LAST_UPDATE_CHECK_TXT = u'lastupdatecheck.txt'
+-FN_OAUTH2SERVICE_JSON = u'oauth2service.json'
+-FN_OAUTH2_TXT = u'oauth2.txt'
++FN_CLIENT_SECRETS_JSON = CONFIG_DIR + u'client_secrets.json'
++FN_EXTRA_ARGS_TXT = CONFIG_DIR + u'extra-args.txt'
++FN_LAST_UPDATE_CHECK_TXT = CONFIG_DIR + u'lastupdatecheck.txt'
++FN_OAUTH2SERVICE_JSON = CONFIG_DIR + u'oauth2service.json'
++FN_OAUTH2_TXT = CONFIG_DIR + u'oauth2.txt'
+ MY_CUSTOMER = u'my_customer'
+ SKUS = {
+ u'1010010001': {
+@@ -653,7 +665,7 @@
# Path to client_secrets.json
GC_CLIENT_SECRETS_JSON = u'client_secrets_json'
# GAM config directory containing client_secrets.json, oauth2.txt, oauth2service.json, extra_args.txt
@@ -24,7 +45,7 @@
# custmerId from gam.cfg or retrieved from Google
GC_CUSTOMER_ID = u'customer_id'
# If debug_level > 0: extra_args[u'prettyPrint'] = True, httplib2.debuglevel = gam_debug_level, appsObj.debug = True
-@@ -724,7 +724,7 @@
+@@ -712,7 +724,7 @@
GC_MEMBER_MAX_RESULTS: 200,
GC_NO_BROWSER: False,
GC_NO_CACHE: False,