summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoiArthurB2022-07-21 15:43:45 +0700
committerRoiArthurB2022-07-21 15:43:45 +0700
commit98ae25ca4461163bc3232219b000aff91b02534b (patch)
treef25c5af81887c30a85a05eef1d40b7ee09ba351a
downloadaur-98ae25ca4461163bc3232219b000aff91b02534b.tar.gz
[182-RC1] Initial push
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--gama-platform-jdk.install21
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f53ba332d9f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gama-platform-jdk
+ pkgdesc = GAMA is a modeling and simulation development environment for building spatially explicit agent-based simulations. JDK embedded version
+ pkgver = 1.8.2.rc1
+ pkgrel = 2
+ url = https://gama-platform.org
+ install = gama-platform-jdk.install
+ arch = x86_64
+ groups =
+ license = GPL-3
+ replaces = gama-platform-jdk
+ replaces = gama-platform
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/gama-platform/gama/releases/download/1.8.2-RC1/GAMA_1.8.2-RC1_Linux_with_JDK.deb
+ sha512sums_x86_64 = fe09e8cad6b38f5cac56689061df781b38ad56fe07c739bd3dc4bb52c3445817217a61a5840538aeb94e3daca623415a7be188375ee9874a1896cc3c061be135
+
+pkgname = gama-platform-jdk
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30508087ad12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by debtap
+# Maintainer: RoiArthurB
+# Contributor: RoiArthurB
+pkgname=gama-platform-jdk
+pkgver=1.8.2.rc1
+pkgrel=2
+pkgdesc="GAMA is a modeling and simulation development environment for building spatially explicit agent-based simulations. JDK embedded version"
+arch=('x86_64')
+url="https://gama-platform.org"
+license=('GPL-3')
+groups=('')
+replaces=('gama-platform-jdk' 'gama-platform')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/gama-platform/gama/releases/download/1.8.2-RC1/GAMA_1.8.2-RC1_Linux_with_JDK.deb")
+sha512sums_x86_64=('fe09e8cad6b38f5cac56689061df781b38ad56fe07c739bd3dc4bb52c3445817217a61a5840538aeb94e3daca623415a7be188375ee9874a1896cc3c061be135')
+
+package(){
+
+ # Extract package data
+ tar -xJ -f data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/gama-platform-jdk.install b/gama-platform-jdk.install
new file mode 100644
index 000000000000..62b097147579
--- /dev/null
+++ b/gama-platform-jdk.install
@@ -0,0 +1,21 @@
+post_install() {
+
+ chown root:root -R /opt/gama-platform
+
+ chmod a+rw -R /opt/gama-platform/Gama.ini
+ chmod a+x -R /opt/gama-platform/Gama
+ chmod a+x -R /opt/gama-platform/headless/gama-headless.sh
+
+ # Add gama-headless.sh shortcut in PATH
+ ln -s /opt/gama-platform/headless/gama-headless.sh /usr/bin/gama-headless
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+
+ rm /usr/bin/gama-headless
+ rm -fr /opt/gama-platform
+}