summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-12-04 13:35:00 +0300
committerMr.Smith19742023-12-04 13:35:00 +0300
commitb6ad2dc59a489f0fb67b8d5e92a4c4a1b16e7691 (patch)
tree2b82bce1caff433584933db9f374c875a1cae12e
parenta0d0bdb8f05ac5f60c6ddff3306806b834da5318 (diff)
downloadaur-b6ad2dc59a489f0fb67b8d5e92a4c4a1b16e7691.tar.gz
updated build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--shared_ptr.diff11
3 files changed, 15 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f84e28d7a007..28f68b6badb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
pkgbase = gambit
pkgdesc = Tools for doing computation in game theory
- pkgver = 15.1.1
- pkgrel = 7
+ pkgver = 16.1.0
+ pkgrel = 1
url = http://www.gambit-project.org
arch = i686
arch = x86_64
license = GPL
- makedepends = git
- makedepends = cython2
- makedepends = gcc6
- depends = wxgtk2
- depends = python2
+ makedepends = cython
+ makedepends = python-setuptools
options = !makeflags
- source = https://sourceforge.net/projects/gambit/files/gambit15/15.1.1/gambit-15.1.1.tar.gz
- source = shared_ptr.diff
- sha256sums = 7ede51739dc868242886815bb875307f5e11bb3789f22c546d3c83194fe75a1c
- sha256sums = f0e2c746379c18b7643ca60565e355a8d2a95efb8823d2f4a63c3ac1f3bde076
+ source = https://github.com/gambitproject/gambit/archive/refs/tags/v16.1.0.tar.gz
+ sha256sums = de3e3d561cf46aeaec135efaf23f41ddef28968d9071251ca8cb6266babece62
pkgname = gambit
-
diff --git a/PKGBUILD b/PKGBUILD
index 1622ba11034f..500fe779c490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,30 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=gambit
-pkgver=15.1.1
-pkgrel=7
+pkgver=16.1.0
+pkgrel=1
pkgdesc="Tools for doing computation in game theory"
arch=('i686' 'x86_64')
url="http://www.gambit-project.org"
license=('GPL')
-depends=('wxgtk2' 'python2')
-makedepends=('git' 'cython2' 'gcc6')
-source=("https://sourceforge.net/projects/$pkgname/files/gambit15/$pkgver/$pkgname-$pkgver.tar.gz" shared_ptr.diff)
-sha256sums=('7ede51739dc868242886815bb875307f5e11bb3789f22c546d3c83194fe75a1c'
- 'f0e2c746379c18b7643ca60565e355a8d2a95efb8823d2f4a63c3ac1f3bde076')
+makedepends=('cython' 'python-setuptools')
+source=("https://github.com/gambitproject/gambit/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('de3e3d561cf46aeaec135efaf23f41ddef28968d9071251ca8cb6266babece62')
options=('!makeflags')
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 < "$srcdir"/shared_ptr.diff
-}
-
build() {
cd "$pkgname-$pkgver"
aclocal
libtoolize
automake --add-missing
autoconf
- CC=gcc-6 CXX=g++-6 CFLAGS=" -fstack-protector" \
- CXXFLAGS=" -fstack-protector" ./configure --prefix=/usr --disable-enumpoly
+ ./configure --prefix=/usr --disable-enumpoly
make
- cd src/python
- python2 setup.py build
+ python setup.py build
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
- cd src/python
- python2 setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir"
}
diff --git a/shared_ptr.diff b/shared_ptr.diff
deleted file mode 100644
index 3d70cbb126ee..000000000000
--- a/shared_ptr.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/libgambit/shared_ptr.h
-+++ b/src/libgambit/shared_ptr.h
-@@ -131,7 +131,7 @@ template <class T> class weak_ptr {
- long use_count(void) const { return *m_count; }
- bool expired(void) const { return *m_count == 0; }
-
-- void swap(const weak_ptr<T> &other) // never throws
-+ void swap(weak_ptr<T> &other) // never throws
- {
- std::swap(m_ptr, other.m_ptr);
- std::swap(m_count, other.m_count);