summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Rødseth2014-01-31 21:20:04 +0000
committerAlexander Rødseth2014-01-31 21:20:04 +0000
commita0173fb5e56cb4f19872f18cc6769d7e2d65c784 (patch)
tree079f4e14dbf6a20d697146d66fad093b5bc14cf7
downloadaur-a0173fb5e56cb4f19872f18cc6769d7e2d65c784.tar.gz
Moving from AUR, 19 votes. Used by "lambdanative".
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd54bb5dda05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 68685 2012-03-31 16:54:07Z arodseth $
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Christian Babeux <christian.babeux@0x80.ca>
+
+_distname=gambc-v4_7_1
+pkgname=gambit-c
+pkgver=4.7.1
+pkgrel=2
+pkgdesc='Scheme R5RS interpreter and compiler (via C)'
+arch=('x86_64' 'i686')
+url='http://dynamo.iro.umontreal.ca/wiki/index.php/Main_Page'
+license=('LGPL2.1' 'Apache')
+source=(http://www.iro.umontreal.ca/~gambit/download/gambit/v4.7/source/${_distname}.tgz)
+
+build() {
+ cd "$_distname"
+
+ ./configure --prefix=/usr --docdir=/usr/share/doc/gambit-c \
+ --infodir=/usr/share/info --libdir=/usr/lib/gambit-c \
+ --enable-gcc-opts --enable-single-host
+ make
+}
+
+package() {
+ make -C "$_distname" install DESTDIR="$pkgdir"
+ # gsc conflicts with the one provided by ghostscript
+ mv "$pkgdir/usr/bin/gsc" "$pkgdir/usr/bin/gambitc"
+ ln -sf /usr/bin/gambitc "$pkgdir/usr/bin/gsc-script"
+}
+
+# vim:set ts=2 sw=2 et: