summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2023-08-10 20:12:18 +0200
committerhaawda2023-08-10 20:12:18 +0200
commite2c00be0c5499ddf7ded6260c1be6ddee10cf8c8 (patch)
tree8a1827cc63d95012a1300478a7392dd482120ec1
parentc6ae934a66aad92e736509f021311f4a2b5f1be4 (diff)
downloadaur-gambit-c-git.tar.gz
add a patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--math.h.patch10
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd396f9dadb9..4686aab794db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gambit-c-git
pkgdesc = Scheme R5RS interpreter and compiler (via C) - git version
- pkgver = 4.9.4.r209.gc2b23f32
+ pkgver = 4.9.5.r5.gf1fbe9aa
pkgrel = 1
url = http://gambitscheme.org
arch = i686
@@ -17,6 +17,8 @@ pkgbase = gambit-c-git
options = !buildflags
options = !makeflags
source = gambit-scheme::git+https://github.com/gambit/gambit.git
+ source = math.h.patch
md5sums = SKIP
+ md5sums = 59f7a342d87e0970a6b3a222d4c954cb
pkgname = gambit-c-git
diff --git a/PKGBUILD b/PKGBUILD
index 80ddbb7c62a5..8d0f7dce83f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=gambit-c-git
-pkgver=4.9.4.r209.gc2b23f32
+pkgver=4.9.5.r5.gf1fbe9aa
pkgrel=1
pkgdesc="Scheme R5RS interpreter and compiler (via C) - git version"
arch=('i686' 'x86_64')
@@ -14,14 +14,20 @@ checkdepends=('git')
provides=('gambit-c')
conflicts=('gambit-c')
options=('staticlibs' '!lto' '!buildflags' '!makeflags')
-source=(gambit-scheme::git+https://github.com/gambit/gambit.git)
-md5sums=('SKIP')
+source=(gambit-scheme::git+https://github.com/gambit/gambit.git math.h.patch)
+md5sums=('SKIP'
+ '59f7a342d87e0970a6b3a222d4c954cb')
pkgver() {
cd gambit-scheme
git describe --tags|sed 's+-+.r+'| sed 's+-+.+' | cut -c2-
}
+prepare() {
+ cd gambit-scheme
+ patch -Np1 < "$srcdir"/math.h.patch
+}
+
build() {
cd gambit-scheme
export CFLAGS=`echo " $CFLAGS " | sed -e "s/-O1 / /g" -e "s/ -O2 / /g" -e "s/ -O3 / /g"`
diff --git a/math.h.patch b/math.h.patch
new file mode 100644
index 000000000000..1b524b6c9e46
--- /dev/null
+++ b/math.h.patch
@@ -0,0 +1,10 @@
+--- a/lib/setup.c
++++ b/lib/setup.c
+@@ -21,6 +21,7 @@
+ #include "mem.h"
+ #include "c_intf.h"
+ #include "actlog.h"
++#include <math.h>
+
+
+ /*---------------------------------------------------------------------------*/