summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-07-03 00:47:41 +0200
committerhaawda2017-07-03 00:47:41 +0200
commitd3224e9f0381e8a534b9182d194dcc4b5b08793e (patch)
tree552c04cca918440844042ca1a546894890e53fab
parent99e7bffffb2695cba2b10b2195c82c94fee06edb (diff)
downloadaur-d3224e9f0381e8a534b9182d194dcc4b5b08793e.tar.gz
Updated version (4.8.8.r240.g2c34b632 -> 4.8.8.r314.gbe322110).
Changelog ========= Merge pull request #273 from vyzo/os-io-fdsets (be322110) With GNU gcc, only use __builtin_add_overflow when version is > 5.0.0 (1b03929a) os_io: ___fdset_realloc shrinks, ___fdset_resize_pstate guarantees that all processors take the barrier. (24e4a6e6) os_io: ___fdset_realloc and ___fdset_init are used even without resizable fdsets (a5783e60) os_io: guard with FDSET_RESIZING in initialization (2bdd7df7) os: USE_FDSET_RESIZING guard for dynamic fdsets (79f81d97) gambit.h.in: fdset.overflow should be volatile (5e8a589a) setup.h: extract common definition of BARRIER from os_io.c and mem.c (99034ea8) os_io: macro use cosmetics (5338f40c) os_io: whitespace (36fbef2a) os_io: ___fdset_realloc: we don't need oldsize and oldbytes (2ef3aff3) os_io: move fdset resizing logic to ___fdset_resize_pstate (932f0213) os_io: ___fdset_init calls ___fdset_realloc, remove __fdset accesors (b777a254) os_io: move overflow clearing/barrier to ___fdset_resize_pstate (8cb05b8b) setup: kill OP_FDSET_CLEAROVL, clear in ___fdset_resize and use a barrier (eb50e945) os_io: ___fdset_resize should return 1 on success and 0 on failure (92088f95) os_io: use ___UWORD for ___fdbits (0790c7f8) os_io: ___vms.os.fdset with global size and overflow (8545be86) os_io: Guard ___fdset_resize_pstate with USE_POSIX (fbd1ed6b) os_io: ___fdset_init/realloc: adhere to Gambig coding style (914c311d) os_io: use ___CAST instead of raw casting in fdset ops (9439b9ca) os_io: ensure initial fdset size is at least as big as the standard fd_set (e690cb99) os_io: placify the c++ compiler (1f4d0d32) setup: ___fdset_resize: ps needs to be called ____ps (320b5cf1) os_io: USE_select_or_poll guard in fdset_resize_pstate (728ce695) os_io: whitespace (e9c47b8b) os_io: don't allocate exceptfds fdset unless we are actually using select (18ddcfc6) os_io: use fdsets for select too; now with unlimited file descriptors (f09fa2d1) setup.c: fd can be negative, so cast the sizeof to int for signed comparison when using select (3fec132e) os_io: ___fdset_realloc: oldbytes and newbytes are needed earlier (2dc6acda) os_thread: restore missing newlines (b6f34e23) os_io: change ___fdset_resize signature to take two fds and no processor state (7940bd4a) os_io: ___device_select: use block for ___processor_state (53386c66) os_io: use ___HIDDEN/___P for fdset procedures (518a565b) os_io: remove ___fdset_state* macros, better memory allocation/error handling (aa78a301) os_io: remove stray semicolon (47cba935) gambit.h.in: restore pruned line (08082438) os_io: remove stray processor_state (e9348890) Merge branch 'master' of github.com:gambit/gambit into os-io-fdsets (23729509) Merge branch 'os-io-raw-devices' into os-io-fdsets (0c59c32c) Merge branch 'os-io-raw-devices' into os-io-fdsets (f0920110) os_io: ___device_cleanup doesn't need ps anymore (0b3333dc) gambit.h.in: guard ___fdset definition, not relevant for windows (6099b4de) os_io: ___device_select shouldn't take ___ps as argument (5b8e31af) Merge branch 'os-io-raw-devices' into os-io-fdsets (011ef8d1) Merge branch 'os-io-raw-devices' into os-io-fdsets (38e50850) Merge branch 'os-io-raw-devices' into os-io-fdsets (7bcae4fc) Merge branch 'os-io-raw-devices' into os-io-fdsets (2ca0f4c6) os_io: rename ___fdset_state to ___fdset (36005691) os_io: ___device_raw_select_virt: FD_ISSET takes references again (5a447bf5) os_io: ___fdset_realloc must return 0 if it's not shrinking (69d517fd) setup: ___fdset_resize: no need for ___PSGET, we already have ___ps (db3b0464) setup.c: ___fdset_resize guard must be USE_poll not ___USE_poll (08fe8f6d) gambit.h.in: Don't define fdset_state guarded by USE_POLL_FOR_SELECT (945beffc) os_io: ___setup_io_pstate: signal heap overflow from fdset allocation. (d34302b8) __fdset_resize: heap overflow check with flag (89988ef3) os_io: eager fdset resizing on device construction (ed4ebfe6) os_io: ___fdset_resize_pstate needs to be available without USE_poll (73e72258) io: ___fdset_resize: synchronous operation to resize fdsets on all processors (6a80b371) os_io: ___fdset_state_init: memzero allocated pollsets (f181ff6b) kill MAX_POLLFDS, they are just MAX_CONDVARS and not useful anywhere else. (691c7d9a) dynamic pollsets: move poll fdstate to ___pstate_os (b7d2849d) dynamic pollsets: fdset_state in ___processor_state and no more TLS (487576db) dynamic pollsets: fix build without --enable-multithread-vms, guard poll state with __SINGLE_THREADED_VMS (105c653e) dynamic pollsets: ___setup_thread_local_state for per thread initialization (58fa8c0b) whitespace cosmetics (8d4e48d6) whitespace cosmetics (55b98bc9) dynamic fdsets for poll: initial allocation at MAX_POLLFDS (85b823fb) dynamic fdsets for poll: fix forgotten __FD ops in select path (1f8ba133) dynamic fdsets for poll: primordial thread needs pollset state too. (67a20a00) dynamic fdsets for poll: practicalities of fdset usage (17ee0cda) dynamic fdsets for poll: resizing logic off by 1 (1822d16b) dynamic fdsets for poll: state management (8d742a47) dynamic fdsets for poll: logic (0c4c0c7e)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4deabc317f45..5be98b88a574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jun 19 23:43:27 UTC 2017
+# Sun Jul 2 22:47:40 UTC 2017
pkgbase = gambit-c-git
pkgdesc = Scheme R5RS interpreter and compiler (via C) - git version
- pkgver = 4.8.8.r240.g2c34b632
+ pkgver = 4.8.8.r314.gbe322110
pkgrel = 1
url = http://gambitscheme.org
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 849a7d445f3e..02180d8582d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=gambit-c-git
-pkgver=4.8.8.r240.g2c34b632
+pkgver=4.8.8.r314.gbe322110
pkgrel=1
pkgdesc="Scheme R5RS interpreter and compiler (via C) - git version"
arch=('i686' 'x86_64')