summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2020-04-26 23:07:30 +0200
committerFabian Bornschein2020-04-26 23:07:30 +0200
commita62d35c7f6340198e069c0858dd78c373a75ccbd (patch)
tree408a6d186c016ad98bdbb8896ee72644ec9c90a3
parent117759137ed5e1dbc55c4cda310a1d16ebeb3bb8 (diff)
downloadaur-a62d35c7f6340198e069c0858dd78c373a75ccbd.tar.gz
fix package, sorry!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--game-devices-udev.install28
3 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04cbde6ed30f..9258ab2c05d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = game-devices-udev
pkgdesc = Udev rules for controllers
pkgver = 0.6
- pkgrel = 0
+ pkgrel = 1
url = https://gitlab.com/Fabish/game-devices-udev
install = game-devices-udev.install
arch = any
license = MIT
+ makedepends = lsb-release
depends = udev
+ depends = lsb-release
source = https://gitlab.com/Fabish/game-devices-udev/-/archive/0.6/game-devices-udev-0.6.zip
source = uinput.conf
sha512sums = c12263703d1d603e013b0537ee4bda12b8e0ca084cc8300fa04a7b59d09e276bfe2701af9c709f7a90312495c2cb4b1517bf6ce91ad923423a1495c81d1c953e
diff --git a/PKGBUILD b/PKGBUILD
index a21d8b17af7b..4112dedac575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Fabian Bornschein <plusfabi(At)gmail(Dot)com>
pkgname=game-devices-udev
pkgver=0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Udev rules for controllers"
url='https://gitlab.com/Fabish/game-devices-udev'
arch=('any')
license=('MIT')
-depends=('udev')
+depends=('udev' 'lsb-release')
+makedepends=('lsb-release')
install=${pkgname}.install
source=("https://gitlab.com/Fabish/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.zip"
"uinput.conf")
@@ -25,6 +26,6 @@ package() {
"${pkgdir}/usr/lib/udev/rules.d/"
# start uinput at boot
- install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" \
+ install -Dm 644 "${srcdir}/uinput.conf" \
"${pkgdir}/usr/lib/modules-load.d/uinput.conf"
}
diff --git a/game-devices-udev.install b/game-devices-udev.install
index efa8b52928a3..cad59ceda0e2 100644
--- a/game-devices-udev.install
+++ b/game-devices-udev.install
@@ -1,5 +1,8 @@
-post_install()
-{
+pre_install() {
+ if [[ $(/usr/bin/lsb_release -is) != "Arch" ]] ; then exit 1; fi
+}
+
+post_install() {
## Load uinput if it is not loaded already
/usr/bin/grep -q 'uinput' /proc/modules
if [ ! $? -eq 0 ] && [ -d "/lib/modules/$(uname -r)" ]
@@ -9,12 +12,25 @@ post_install()
## reload udev rules
/usr/bin/udevadm control --reload-rules
+ printf "\nThanks for using my pkg šŸ˜Š\n\n"
}
-post_upgrade()
-{
- post_install
-
+pre_upgrade() {
+ if [[ $(/usr/bin/lsb_release -is) != "Arch" ]] ; then exit 1; fi
+}
+
+post_upgrade() {
## reload udev rules
/usr/bin/udevadm control --reload-rules
+ printf "\nThanks for still using my pkg šŸ˜Š\n\n"
+}
+
+#pre_remove() {
+#}
+
+post_remove() {
+ ## reload udev rules
+ /usr/bin/udevadm control --reload-rules
+ printf "\nYou need to reboot your system now"
+ printf "\nšŸ–ļøšŸ–ļø bye bye šŸ˜ž\n\n"
}