summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-12-26 22:19:10 +0300
committerIgor Dyatlov2022-12-26 22:19:10 +0300
commit6c12b78158c6f2cc9873b35c9c672e072a3eafe9 (patch)
treec414417b1403945335156af41338e268e223331c
parent5e17c20193eaaf48aa43a23d46fc5637f050cbb7 (diff)
downloadaur-6c12b78158c6f2cc9873b35c9c672e072a3eafe9.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98dc13ab2e2c..ec41dbac1b0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = game-of-life
pkgdesc = A simulator of Conway's game of life
- pkgver = 0.1.4_3
+ pkgver = 0.2.0_1
pkgrel = 1
url = https://github.com/sixpounder/game-of-life
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = game-of-life
makedepends = meson
makedepends = cargo
depends = libadwaita
- source = game-of-life-0.1.4_3.tar.gz::https://github.com/sixpounder/game-of-life/archive/v0.1.4-3.tar.gz
- b2sums = 1201790e460afc3e479861bc6114a20379b5346abe85f59103f3987a9d1fe0a3118de6177b7f0be23165573619e6681b4eb2a8b13a0571a1fb21fa8c3806b93e
+ source = game-of-life-0.2.0_1.tar.gz::https://github.com/sixpounder/game-of-life/archive/v0.2.0-1.tar.gz
+ b2sums = fb2a5458ede8ccd47e00b1a8fae3ba928558058993bc07771688d2a000bca97077fd27bbc021211c27929f1b873941a548424a822bdf006f868e7912eb16ff65
pkgname = game-of-life
diff --git a/PKGBUILD b/PKGBUILD
index 5ec5e55a25e1..541fd1f5eda2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=game-of-life
-pkgver=0.1.4_3
+pkgver=0.2.0_1
pkgrel=1
pkgdesc="A simulator of Conway's game of life"
arch=('x86_64' 'aarch64')
@@ -11,10 +11,14 @@ depends=('libadwaita')
makedepends=('meson' 'cargo')
checkdepends=('appstream-glib')
source=($pkgname-$pkgver.tar.gz::$url/archive/v${pkgver//_/-}.tar.gz)
-b2sums=('1201790e460afc3e479861bc6114a20379b5346abe85f59103f3987a9d1fe0a3118de6177b7f0be23165573619e6681b4eb2a8b13a0571a1fb21fa8c3806b93e')
+b2sums=('fb2a5458ede8ccd47e00b1a8fae3ba928558058993bc07771688d2a000bca97077fd27bbc021211c27929f1b873941a548424a822bdf006f868e7912eb16ff65')
build() {
- arch-meson "$pkgname-$pkgver" build
+ local meson_options=(
+ --buildtype release
+ )
+
+ arch-meson "$pkgname-${pkgver//_/-}" build "${meson_options[@]}"
meson compile -C build
}