summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonKeyPWN2022-07-31 09:34:24 +0200
committerDonKeyPWN2022-07-31 09:34:24 +0200
commit2d2702b779de7a2279e2d97ef1d4c39199a624d8 (patch)
tree802064c32621447c1d959d0aa5c6b7816fa19b10
downloadaur-2d2702b779de7a2279e2d97ef1d4c39199a624d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df0e95cadd63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gamecube-tools
+ pkgdesc = gamecube tools
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/devkitPro/gamecube-tools
+ arch = x86_64
+ groups = gamecube-dev
+ groups = wii-dev
+ license = GPL3
+ makedepends = freeimage
+ makedepends = git
+ source = gamecube-tools-1.0.3::git+https://github.com/devkitPro/gamecube-tools.git#commit=21e671615cd9531c9c14c8f249bdb231af27f616
+ sha256sums = SKIP
+
+pkgname = gamecube-tools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f76b253b7ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/gamecube-tools-*.pkg.tar.*
+/gamecube-tools-*/
+/pkg/
+/src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56bac5ac7550
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: DonKeyPWN
+pkgname=gamecube-tools
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='gamecube tools'
+arch=('x86_64')
+url='https://github.com/devkitPro/gamecube-tools'
+license=('GPL3')
+groups=(
+ 'gamecube-dev'
+ 'wii-dev'
+)
+makedepends=(
+ 'freeimage'
+ 'git'
+)
+
+pkgcid=21e671615cd9531c9c14c8f249bdb231af27f616 # Commit ID from https://github.com/devkitPro/gamecube-tools/tree/v${pkgver}
+source=(
+ "${pkgname}-${pkgver}::git+https://github.com/devkitPro/gamecube-tools.git#commit=${pkgcid}"
+)
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix="${pkgdir}/opt/devkitpro/tools"
+ make
+}
+
+package() {
+ install -d ${pkgdir}/opt/devkitpro/{licenses/gamecube-tools,tools}
+ cp ${pkgname}-${pkgver}/COPYING ${pkgdir}/opt/devkitpro/licenses/gamecube-tools/
+ make -C "${pkgname}-${pkgver}" install
+}