summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-04-12 23:30:59 +0200
committerFabioLolix2023-04-12 23:30:59 +0200
commitc748dc592e19ce604b82e105a60552441ab23da0 (patch)
tree5fdd52d556709e14da50a6494c2ff0bce79e831c
parent0c2be79bd4abd8831642acba56333d9f0ed0a0bb (diff)
downloadaur-gamehub.tar.gz
add proton patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46d9c78465eb..0ff919c71374 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamehub
pkgdesc = Games manager, downloader, library that supports GOG, Steam and Humble Bundle
pkgver = 0.16.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://tkashkin.github.io/projects/gamehub/
arch = i686
arch = x86_64
@@ -25,6 +25,8 @@ pkgbase = gamehub
options = !strip
options = debug
source = git+https://github.com/tkashkin/GameHub.git#tag=0.16.3-2-master
+ source = https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/gamehub-protonfix.patch
sha256sums = SKIP
+ sha256sums = 26e267dade0b416699707a8612aa4f1c32b60a08889c217127ddf1843b7302ba
pkgname = gamehub
diff --git a/PKGBUILD b/PKGBUILD
index a4b287e247a9..4ccd4298ded0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gamehub
_pkgver=0.16.3-2
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle"
arch=(i686 x86_64 armv6h armv7h aarch64)
url="https://tkashkin.github.io/projects/gamehub/"
@@ -16,8 +16,15 @@ depends=(gtk3 glib2 libgee libsoup json-glib sqlite webkit2gtk libmanette libxts
makedepends=(git meson ninja vala)
options=(!strip debug)
#source=("git+https://github.com/tkashkin/GameHub/archive/${_pkgver}-master.tar.gz")
-source=("git+https://github.com/tkashkin/GameHub.git#tag=${_pkgver}-master")
-sha256sums=('SKIP')
+source=("git+https://github.com/tkashkin/GameHub.git#tag=${_pkgver}-master"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/gamehub-protonfix.patch")
+sha256sums=('SKIP'
+ '26e267dade0b416699707a8612aa4f1c32b60a08889c217127ddf1843b7302ba')
+
+prepare() {
+ cd "GameHub"
+ patch -Np1 -i ../gamehub-protonfix.patch
+}
build() {
cd "GameHub"