summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2019-09-22 00:13:17 +0200
committerFabioLolix2019-09-22 00:13:17 +0200
commit4af3e4457d97da25548ec409c5b47f79a1dbe9a4 (patch)
treea1b8e933c9237b3618f02eeb83bf826625e29c7b
parentc6e9f87a1c9b8b15e657846d526adb17016bcb6c (diff)
downloadaur-4af3e4457d97da25548ec409c5b47f79a1dbe9a4.tar.gz
remove -master from _pkgver (always use master for stable release)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baf9e73a4dab..26e4a498309b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamehub
pkgdesc = Games manager, downloader, library that supports GOG, Steam and Humble Bundle. Designed for Pantheon Shell
- pkgver = 0.14.2.1.master
+ pkgver = 0.14.2.1
pkgrel = 1
url = https://github.com/tkashkin/GameHub
arch = i686
@@ -23,7 +23,7 @@ pkgbase = gamehub
depends = libxtst
options = !strip
options = debug
- source = GameHub-0.14.2.1.master.tar.gz::https://github.com/tkashkin/GameHub/archive/0.14.2-1-master.tar.gz
+ source = GameHub-0.14.2.1.tar.gz::https://github.com/tkashkin/GameHub/archive/0.14.2-1-master.tar.gz
sha256sums = fe230da7ab63211ba08b5b84fda8633784e3e503b71dc432096ee315d6b15dae
pkgname = gamehub
diff --git a/PKGBUILD b/PKGBUILD
index b2ce19b666c9..0132d0eac355 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Robert Stoffers <rstoffers@gmail.com>
pkgname=gamehub
-_pkgver=0.14.2-1-master
+_pkgver=0.14.2-1
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle. Designed for Pantheon Shell"
@@ -15,17 +15,17 @@ license=(GPL3)
depends=(gtk3 glib2 libgee libsoup json-glib sqlite webkit2gtk libmanette libxtst)
makedepends=(meson ninja vala)
options=(!strip debug)
-source=("GameHub-$pkgver.tar.gz::https://github.com/tkashkin/GameHub/archive/${_pkgver}.tar.gz")
+source=("GameHub-$pkgver.tar.gz::https://github.com/tkashkin/GameHub/archive/${_pkgver}-master.tar.gz")
sha256sums=('fe230da7ab63211ba08b5b84fda8633784e3e503b71dc432096ee315d6b15dae')
build() {
- cd "GameHub-$_pkgver"
+ cd "GameHub-$_pkgver-master"
CFLAGS="$CFLAGS -O0" meson . build --prefix=/usr -Ddistro=arch --buildtype=debug
ninja -C build
}
package() {
- cd "GameHub-$_pkgver"
+ cd "GameHub-$_pkgver-master"
DESTDIR="${pkgdir}" ninja -C build install
ln -s /usr/bin/com.github.tkashkin.gamehub "$pkgdir/usr/bin/gamehub"
}