summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Stoffers2018-07-20 22:25:25 +1000
committerRobert Stoffers2018-07-20 22:25:25 +1000
commit5fdd2458c44b318ca11461e83c35f056df24431c (patch)
tree4efb2d7300210d60b01be1cc9887c39f82381d91
downloadaur-5fdd2458c44b318ca11461e83c35f056df24431c.tar.gz
initial upload
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD26
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab7cca451e74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gamehub
+ pkgdesc = Games manager/downloader/library written in Vala for Elementary OS that supports GOG and Steam
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://github.com/tkashkin/GameHub
+ arch = any
+ license = unknown
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = granite
+ depends = gtk3
+ depends = glibc
+ depends = webkit2gtk
+ depends = json-glib
+ depends = libgee
+ depends = libsoup
+ depends = sqlite
+ depends = gdk-pixbuf2
+ depends = cairo
+ conflicts = gamehub-git
+ source = GameHub-0.5.4.tar.gz::https://github.com/tkashkin/GameHub/archive/0.5.4.tar.gz
+ md5sums = 0020379a2a52a39118a7932cb127b7b5
+
+pkgname = gamehub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7731fedebcb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Robert Stoffers <rstoffers@gmail.com>
+
+pkgname=gamehub
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Games manager/downloader/library written in Vala for Elementary OS that supports GOG and Steam"
+arch=('any')
+url="https://github.com/tkashkin/GameHub"
+license=('unknown')
+depends=('granite' 'gtk3' 'glibc' 'webkit2gtk' 'json-glib' 'libgee' 'libsoup' 'sqlite' 'gdk-pixbuf2' 'cairo')
+makedepends=('meson' 'ninja' 'vala')
+conflicts=('gamehub-git')
+source=("GameHub-$pkgver.tar.gz"::https://github.com/tkashkin/GameHub/archive/0.5.4.tar.gz)
+md5sums=('0020379a2a52a39118a7932cb127b7b5')
+
+build() {
+ cd "GameHub-$pkgver"
+ meson build --prefix=$pkgdir/usr
+ cd build
+ ninja
+}
+
+package() {
+ cd "GameHub-$pkgver"/build
+ sudo ninja install
+}