summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Stoffers2018-07-26 21:05:41 +1000
committerRobert Stoffers2018-07-26 21:05:41 +1000
commite4df72d88ffac3ae7f4185e7551fb7491a14eb46 (patch)
tree432e1954d008999a8b2bd7d1390f3956c2467a98
parenta2694c0083ca4d44e4de1e069e1cff86ac12eb32 (diff)
downloadaur-e4df72d88ffac3ae7f4185e7551fb7491a14eb46.tar.gz
updated paths, updated version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1ed1d72d62e..64f9749e6dde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamehub
pkgdesc = Games manager/downloader/library written in Vala that supports GOG, Steam and Humble Bundle
- pkgver = 0.6.1
+ pkgver = 0.6.2
pkgrel = 1
url = https://github.com/tkashkin/GameHub
arch = any
@@ -19,8 +19,8 @@ pkgbase = gamehub
depends = gdk-pixbuf2
depends = cairo
conflicts = gamehub-git
- source = GameHub-0.6.1.tar.gz::https://github.com/tkashkin/GameHub/archive/0.6.1.tar.gz
- md5sums = ea8ab308917b91a25c72a39d17b4c860
+ source = GameHub-0.6.2.tar.gz::https://github.com/tkashkin/GameHub/archive/0.6.2.tar.gz
+ md5sums = 15f58636acd5946185fbca1c65a6a17c
pkgname = gamehub
diff --git a/PKGBUILD b/PKGBUILD
index bdf84272734c..cc257b8e78d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Robert Stoffers <rstoffers@gmail.com>
pkgname=gamehub
-pkgver=0.6.1
+pkgver=0.6.2
pkgrel=1
pkgdesc="Games manager/downloader/library written in Vala that supports GOG, Steam and Humble Bundle"
arch=('any')
@@ -11,18 +11,17 @@ depends=('granite' 'gtk3' 'glibc' 'webkit2gtk' 'json-glib' 'libgee' 'libsoup' 's
makedepends=('meson' 'ninja' 'vala')
conflicts=('gamehub-git')
source=("GameHub-$pkgver.tar.gz"::https://github.com/tkashkin/GameHub/archive/$pkgver.tar.gz)
-md5sums=('98082a10b95208035c24fd1eb52fa3c8')
+md5sums=('15f58636acd5946185fbca1c65a6a17c')
build() {
cd "GameHub-$pkgver"
- meson build --prefix=$pkgdir/usr -Ddistro=arch
+ meson build --prefix=/usr -Ddistro=arch
cd build
ninja
- rm -f ../meson/post_install.py # don't do post install to avoid generating unnecessary files
- touch ../meson/post_install.py # menson chucks a wobbly if it doesn't exist
}
package() {
cd "GameHub-$pkgver"/build
- ninja install
+ DESTDIR=$pkgdir ninja install
+ sudo ln -s /usr/bin/com.github.tkashkin.gamehub /usr/bin/gamehub
}