summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-08-25 23:38:57 +0200
committerFabioLolix2021-08-25 23:38:57 +0200
commite7f52e01e54709cade62b3dbca84a6a8634432d9 (patch)
treead37efb52eb72cf21f41f955b909bed435188f7f
parent2e5c5189a7a918f9255e044c8c55b06a01db19b0 (diff)
downloadaur-e7f52e01e54709cade62b3dbca84a6a8634432d9.tar.gz
add symlink, change build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d0278a8705e..4c23f7c7912e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamehub-git
pkgdesc = Games manager, downloader, library that supports GOG, Steam and Humble Bundle
- pkgver = 0.16.0.28.dev.r0.g53606c8
+ pkgver = 0.16.0.108.dev.r0.gee370d2
pkgrel = 1
url = https://tkashkin.tk/projects/gamehub/
arch = i686
@@ -30,4 +30,3 @@ pkgbase = gamehub-git
sha256sums = SKIP
pkgname = gamehub-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8069ce297ab8..ecae71f16cc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Helder Bertoldo <helder.bertoldo@gmail.com>
pkgname=gamehub-git
-pkgver=0.16.0.28.dev.r0.g53606c8
+pkgver=0.16.0.108.dev.r0.gee370d2
pkgrel=1
pkgdesc="Games manager, downloader, library that supports GOG, Steam and Humble Bundle"
arch=(i686 x86_64 armv6h armv7h aarch64)
@@ -26,11 +26,13 @@ pkgver() {
build() {
cd "GameHub"
- CFLAGS="$CFLAGS -O0" meson . build --prefix=/usr -Ddistro=arch --buildtype=debug
+ #CFLAGS="$CFLAGS -O0" meson . build --prefix=/usr -Ddistro=arch --buildtype=debug
+ meson . build --prefix=/usr -Ddistro=arch --buildtype=debug
ninja -C build
}
package() {
cd "GameHub"
DESTDIR="${pkgdir}" ninja -C build install
+ ln -s /usr/bin/com.github.tkashkin.gamehub "${pkgdir}/usr/bin/gamehub"
}