summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2018-04-10 12:34:59 +0200
committerMinze Zwerver2018-04-10 12:36:00 +0200
commit985b5df9a6c7cfbcce0fbd40be43d047e9015800 (patch)
treec6419aaedd38312f73909386b0ca20a0ebdc24c0
downloadaur-985b5df9a6c7cfbcce0fbd40be43d047e9015800.tar.gz
1st commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f20184ea669b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gamemode
+ pkgdesc = GameMode is a daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/FeralInteractive/gamemode.git
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = ninja
+ makedepends = pkg-config
+ depends = systemd
+ depends = polkit
+ provides = gamemode
+ source = https://github.com/FeralInteractive/gamemode/archive/1.0.tar.gz
+ sha256sums = bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d
+
+pkgname = gamemode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dbee26dd57c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ysblokje <ysblokje at gmail dot com>
+pkgname=('gamemode')
+pkgver=1.0
+pkgrel=1
+pkgdesc="GameMode is a daemon/lib combo for Linux that allows games to request a set of optimisations be temporarily applied to the host OS."
+arch=('x86_64')
+url="https://github.com/FeralInteractive/gamemode.git"
+license=('MIT')
+depends=('systemd' 'polkit')
+makedepends=('meson' 'ninja' 'pkg-config')
+provides=('gamemode')
+source=("https://github.com/FeralInteractive/gamemode/archive/$pkgver.tar.gz")
+sha256sums=('bc458e294221e06b63edb286dd3dc1b541014941027198600959b27b11dd6a9d')
+
+build() {
+ cd gamemode-$pkgver
+ meson --prefix=/usr build -Dwithsystemd-user-unit-dir=/etc/systemd/user
+ cd build
+ ninja
+}
+
+package() {
+ cd gamemode-$pkgver/build
+ DESTDIR=$pkgdir ninja install
+}
+