summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Bruce2019-09-06 01:24:45 +1000
committerCorey Bruce2019-09-06 01:24:45 +1000
commitfa07cefded9b3bb467ff109ed43e3396b0a13372 (patch)
tree1c6e564d4573d96f390ee7104699056419bb2702
downloadaur-fa07cefded9b3bb467ff109ed43e3396b0a13372.tar.gz
Gamer World PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20bab6e714b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gamerworld
+ pkgdesc = Play games all in one place
+ pkgver = 1.1.3
+ pkgrel = 5
+ url = https://gitlab.com/gamerworld/application
+ arch = x86_64
+ license = GPL
+ provides = gamerworld
+ source = https://gitlab.com/gamerworld/application/raw/Binaries/GamerWorld-linux-x64.tar.gz
+ md5sums = SKIP
+
+pkgname = gamerworld
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..783bb945d82a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Corey Bruce <cdfrosty@gmail.com>
+
+pkgname=gamerworld
+_pkgname=GamerWorld-linux-x64
+pkgver=1.1.3
+pkgrel=5
+pkgdesc="Play games all in one place"
+arch=('x86_64')
+url="https://gitlab.com/gamerworld/application"
+license=('GPL')
+depends=()
+makedepends=( )
+provides=('gamerworld')
+conflicts=()
+source=("https://gitlab.com/gamerworld/application/raw/Binaries/GamerWorld-linux-x64.tar.gz")
+
+md5sums=("SKIP")
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p $pkgdir/opt/GamerWorld/
+ # Exec bit
+ chmod 755 "$pkgdir/opt/GamerWorld/"
+ cp -r ./ $pkgdir/opt/GamerWorld/
+
+# Desktop Entry
+ install -Dm 644 "${pkgdir}/opt/GamerWorld/GamerWorld.desktop" "${pkgdir}/usr/share/applications/GamerWorld.desktop"
+ sed -i s%/usr/share%/opt% ${pkgdir}/usr/share/applications/GamerWorld.desktop
+}