summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2021-01-09 22:58:26 +1000
committergameslayer2021-01-09 22:58:26 +1000
commit8fd7ca341677a5dc63b93e29faf5ce7ba21ee4b5 (patch)
tree2522ed4f61c0c9d82d9daeed7c97cbbf25738867
downloadaur-8fd7ca341677a5dc63b93e29faf5ce7ba21ee4b5.tar.gz
committing PKG file to AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12e8425e9269
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gamerworld-bin
+ pkgdesc = Play games all in one place
+ pkgver = 1.2.0
+ pkgrel = 5
+ url = https://gitlab.com/gamerworld/application
+ arch = x86_64
+ arch = arm7h
+ arch = aarch64
+ license = GPL
+ makedepends = unzip
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ conflicts = gamerworld-git
+ source_x86_64 = https://gitlab.com/gamerworld/gw-binaries/-/raw/master/GamerWorld-linux-x64.tar.gz
+ sha256sums_x86_64 = SKIP
+ source_aarch64 = https://gitlab.com/gamerworld/gw-binaries/-/raw/master/GamerWorld-linux-arm64.tar.gz
+ sha256sums_aarch64 = SKIP
+
+pkgname = gamerworld-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf115c69660a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=gamerworld-bin
+_pkgname=GamerWorld-bin
+pkgver=1.2.0
+pkgrel=5
+_pkgrel_x86_64=1
+_pkgrel_armv7h=1
+_pkgrel_aarch64=1
+pkgdesc="Play games all in one place"
+arch=('x86_64' 'arm7h' 'aarch64')
+url="https://gitlab.com/gamerworld/application"
+license=('GPL')
+depends=('nss' 'gtk3' 'libxss')
+makedepends=('unzip')
+conflicts=("gamerworld-git")
+sha256sums_x86_64=('SKIP')
+sha256sums_armv7h=('SKIP')
+sha256sums_aarch64=('SKIP')
+source_x86_64=("https://gitlab.com/gamerworld/gw-binaries/-/raw/master/GamerWorld-linux-x64.tar.gz")
+source_armv7h=("https://gitlab.com/gamerworld/gw-binaries/-/raw/master/GamerWorld-linux-armv7l.tar.gz")
+source_aarch64=("https://gitlab.com/gamerworld/gw-binaries/-/raw/master/GamerWorld-linux-arm64.tar.gz")
+
+
+package() {
+ for dir in GamerWorld-linux-*/ ; do mv "${dir}" "$_pkgname" ;done
+ cd $_pkgname
+ install -dm755 "$pkgdir/opt/GamerWorld"
+ cp -r ./ "$pkgdir/opt/GamerWorld"
+
+
+ # Link to binary
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/GamerWorld" "$pkgdir/usr/bin/GamerWorld"
+
+ # Desktop Entry
+ install -Dm644 "$srcdir/$_pkgname/resources/app/GamerWorld.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}