summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMerlin Jehli2024-05-15 00:20:02 +0200
committerMerlin Jehli2024-05-15 00:20:02 +0200
commitf7549ae5552998160ac021c262fdd093aba9a80e (patch)
treefafb2ab7cc35b2148884f509c8d188d843917e8c
parentc2909823b552e6c19217aeb1520c596b4980e7f1 (diff)
downloadaur-f7549ae5552998160ac021c262fdd093aba9a80e.tar.gz
Revert "bug fix"
This reverts commit ac174ca1aefe18b80766d277a4860ff894657f15.
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23c620f128e1..2054f2f451d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -80,17 +80,15 @@ sha256sums=('e9bb0560dcf6e9ba3a6b0a47b005609d9efea80d4fcb064b0aa4f60681338f4a'
prepare() {
cd "$srcdir/$_pkgname"
- git submodule update --init --recursive
-
+ # meson subprojects download
+ git config submodule.src/reshade.url ../reshade
+ git config submodule.thirdparty/SPIRV-Headers.url ../SPIRV-Headers
+ git -c protocol.file.allow=always submodule update --init --recursive
+
# make stb.wrap use our local clone
rm -rf subprojects/stb
git clone "$srcdir/stb" subprojects/stb
cp -av subprojects/packagefiles/stb/* subprojects/stb/ # patch from the .wrap we elided
-
- # Replace spirv-headers include with the system directory
- sed -i 's^../thirdparty/SPIRV-Headers/include/spirv/^/usr/include/spirv/^' src/meson.build
-
-
patch -Np1 -i ../720p.patch