summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-09-11 23:50:36 +0200
committerSefa Eyeoglu2020-09-11 23:50:36 +0200
commit0cbcc8bed316b16a8c8af40d75d61f32eac4ba06 (patch)
tree8a89e1741cecb05a41580ed59941426d95b835a3
parentb8a187a9fa8c4e5a14969b63606264b14a85b2ca (diff)
downloadaur-0cbcc8bed316b16a8c8af40d75d61f32eac4ba06.tar.gz
upgpkg: gamescope-git 3.6.9.r21.g5644232-1
fix: update use-system-libs.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--use-system-libs.patch27
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14b70b6ba61c..4c74dc59d291 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.6.3.r3.g4524ac3
+ pkgver = 3.6.9.r21.g5644232
pkgrel = 1
url = https://github.com/Plagman/gamescope
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = gamescope-git
source = git+https://github.com/Plagman/gamescope.git
source = use-system-libs.patch
sha512sums = SKIP
- sha512sums = 2459cca2891c2de061a35dbb8896ac16c51e86e338d042e7a40f8742b59325d412232b653c6a36347af528cde8226e250f315a5b6c98d0b76ac5001099c7a245
+ sha512sums = a36d6bef5ea19a0754ab82df5bc2c5f64c23321fde7be33073953dad76eb8c0af64ae1b5723f4e778a403c6bf75d4df27a524899de3b412d2bacd1cd4052e86a
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index 0b01520990e9..224088089c15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.6.3.r3.g4524ac3
+pkgver=3.6.9.r21.g5644232
pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
@@ -15,7 +15,7 @@ conflicts=($_pkgname "steamcompmgr")
source=("git+https://github.com/Plagman/gamescope.git"
"use-system-libs.patch")
sha512sums=('SKIP'
- '2459cca2891c2de061a35dbb8896ac16c51e86e338d042e7a40f8742b59325d412232b653c6a36347af528cde8226e250f315a5b6c98d0b76ac5001099c7a245')
+ 'a36d6bef5ea19a0754ab82df5bc2c5f64c23321fde7be33073953dad76eb8c0af64ae1b5723f4e778a403c6bf75d4df27a524899de3b412d2bacd1cd4052e86a')
pkgver() {
diff --git a/use-system-libs.patch b/use-system-libs.patch
index c6fa98220e4d..c1c1e23ba62a 100644
--- a/use-system-libs.patch
+++ b/use-system-libs.patch
@@ -1,18 +1,18 @@
-From 693ee2043822c0d3b724932bc17216032682c293 Mon Sep 17 00:00:00 2001
+From 4f8f8c2d12a03cddc3ade2ceba13525e086d929d Mon Sep 17 00:00:00 2001
From: Sefa Eyeoglu <contact@scrumplex.net>
-Date: Thu, 21 May 2020 20:12:37 +0200
+Date: Fri, 11 Sep 2020 23:48:34 +0200
Subject: [PATCH] packaging/archlinux: use system libliftoff and wlroots
---
- meson.build | 12 ++++--------
- 1 file changed, 4 insertions(+), 8 deletions(-)
+ meson.build | 13 ++++---------
+ 1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/meson.build b/meson.build
-index 7d2fd7d..fd5544a 100644
+index d4fadab..23de301 100644
--- a/meson.build
+++ b/meson.build
-@@ -44,9 +44,8 @@ math = cc.find_library('m')
- thread_dep = dependency('threads')
+@@ -45,9 +45,8 @@ thread_dep = dependency('threads')
+ cap_dep = cc.find_library('cap')
sdl_dep = dependency('SDL2')
-wlroots_proj = subproject('wlroots', default_options:
@@ -23,27 +23,28 @@ index 7d2fd7d..fd5544a 100644
shadercompiler = find_program('glslangValidator')
-@@ -60,9 +59,6 @@ spirv_shader = custom_target('shader_target',
+@@ -61,10 +60,6 @@ spirv_shader = custom_target('shader_target',
install : false,
)
-liftoff_proj = subproject('libliftoff', default_options:
- ['default_library=static'])
-libftoff_dep = liftoff_proj.get_variable('liftoff')
-
+-
executable(
'gamescope',
-@@ -76,8 +72,8 @@ executable(
+ 'src/steamcompmgr.cpp',
+@@ -77,8 +72,8 @@ executable(
dependencies : [
dep_x11, dep_xdamage, dep_xcomposite, dep_xrender, dep_xext,
dep_xxf86vm, pixman_dep, drm_dep, wayland_server, wayland_protos,
- libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots_static_dep,
-- vulkan_dep, libftoff_dep, dep_xtst
+- vulkan_dep, libftoff_dep, dep_xtst, cap_dep
+ libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots,
-+ vulkan_dep, liftoff, dep_xtst
++ vulkan_dep, liftoff, dep_xtst, cap_dep
],
install: true,
)
--
-2.26.2
+2.28.0