summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-05-21 19:56:11 +0200
committerSefa Eyeoglu2020-05-21 19:56:11 +0200
commit1ec4d1ed397caa1d5699721be1f7b4658306c955 (patch)
tree6b74e5a821a6f222c13712a9a2a25570b1fd6774
parent3c5ab1b4bb76b2e2de979ba8e17c36b4ac270c67 (diff)
downloadaur-1ec4d1ed397caa1d5699721be1f7b4658306c955.tar.gz
refactor: manage submodule as a source, use patch instead of git am
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--use-system-wlroots.patch31
3 files changed, 22 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f039176a3892..a078e3ce099e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
- pkgver = 3.6.1.r24.g66722b1
- pkgrel = 2
+ pkgver = 3.6.1.r23.g5ab3129
+ pkgrel = 1
url = https://github.com/Plagman/gamescope
arch = x86_64
license = custom:BSD-2-Clause
makedepends = git
makedepends = meson
makedepends = ninja
+ makedepends = patch
depends = wlroots-git
depends = sdl2
depends = libxcomposite
@@ -20,9 +21,11 @@ pkgbase = gamescope-git
conflicts = steamcompmgr
conflicts = libliftoff
source = git+https://github.com/Plagman/gamescope.git
+ source = git+https://github.com/emersion/libliftoff.git#commit=cfeee41ec1aa03578bfbe4cd513a25e84c407dec
source = use-system-wlroots.patch
sha512sums = SKIP
- sha512sums = 6f3b95ac6d95cfc5c1dd82c995b7492505507171f7d4df5c59dba3e8b66eda696328e71fc49e4df8cbf8a7aab252946c9ceb75080d062b30b8cf31dedba58717
+ sha512sums = SKIP
+ sha512sums = 11878aae7f7c0f7ef01f0b85ce83d5fcea2b339d309dc34dea55d7bcd04ea9d03257f23313c464296b46e1e61e14b91d007c7cfb0d993434afab07f280d9961c
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index 6c10a2ea0b83..252961561571 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
-pkgver=3.6.1.r24.g66722b1
-pkgrel=2
+pkgver=3.6.1.r23.g5ab3129
+pkgrel=1
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
url="https://github.com/Plagman/gamescope"
license=("custom:BSD-2-Clause")
depends=("wlroots-git" "sdl2" "libxcomposite" "vulkan-icd-loader" "libxtst")
-makedepends=("git" "meson" "ninja")
+makedepends=("git" "meson" "ninja" "patch")
provides=($_pkgname "steamcompmgr" "libliftoff")
conflicts=($_pkgname "steamcompmgr" "libliftoff")
-source=("git+https://github.com/Plagman/gamescope.git"
+source=("git+https://github.com/Plagman/gamescope.git"
+ "git+https://github.com/emersion/libliftoff.git#commit=cfeee41ec1aa03578bfbe4cd513a25e84c407dec"
"use-system-wlroots.patch")
sha512sums=('SKIP'
- '6f3b95ac6d95cfc5c1dd82c995b7492505507171f7d4df5c59dba3e8b66eda696328e71fc49e4df8cbf8a7aab252946c9ceb75080d062b30b8cf31dedba58717')
+ 'SKIP'
+ '11878aae7f7c0f7ef01f0b85ce83d5fcea2b339d309dc34dea55d7bcd04ea9d03257f23313c464296b46e1e61e14b91d007c7cfb0d993434afab07f280d9961c')
pkgver() {
@@ -27,9 +29,11 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- git am "../use-system-wlroots.patch"
-
+ patch -p1 < "../use-system-wlroots.patch"
+ git rm "subprojects/wlroots" # remove wlroots submodule, to avoid downloading unneccessary dependencies
git submodule init
+ git config submodule.subprojects/libliftoff.url $srcdir/libliftoff
+
git submodule update
}
diff --git a/use-system-wlroots.patch b/use-system-wlroots.patch
index c7bd9d6edbd7..0ce92bf8bed2 100644
--- a/use-system-wlroots.patch
+++ b/use-system-wlroots.patch
@@ -1,26 +1,12 @@
-From 159e0a80b83ef9d2a55ef27f4a68c520a04526b4 Mon Sep 17 00:00:00 2001
+From 47b37ccab5e596b70a433edcd72aa528b08a3f64 Mon Sep 17 00:00:00 2001
From: Sefa Eyeoglu <contact@scrumplex.net>
-Date: Wed, 20 May 2020 12:43:05 +0200
-Subject: [PATCH] packaging/archlinux: Use global wlroots library
+Date: Thu, 21 May 2020 19:30:26 +0200
+Subject: [PATCH] packaging/archlinux: use system wlroots
---
- .gitmodules | 3 ---
- meson.build | 6 ++----
- subprojects/wlroots | 1 -
- 3 files changed, 2 insertions(+), 8 deletions(-)
- delete mode 160000 subprojects/wlroots
+ meson.build | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
-diff --git a/.gitmodules b/.gitmodules
-index dcdc8b8..984b052 100644
---- a/.gitmodules
-+++ b/.gitmodules
-@@ -1,6 +1,3 @@
--[submodule "subprojects/wlroots"]
-- path = subprojects/wlroots
-- url = https://github.com/swaywm/wlroots.git
- [submodule "subprojects/libliftoff"]
- path = subprojects/libliftoff
- url = https://github.com/emersion/libliftoff.git
diff --git a/meson.build b/meson.build
index 7d2fd7d..a275d50 100644
--- a/meson.build
@@ -45,13 +31,6 @@ index 7d2fd7d..a275d50 100644
vulkan_dep, libftoff_dep, dep_xtst
],
install: true,
-diff --git a/subprojects/wlroots b/subprojects/wlroots
-deleted file mode 160000
-index 2176c63..0000000
---- a/subprojects/wlroots
-+++ /dev/null
-@@ -1 +0,0 @@
--Subproject commit 2176c63856df4e411df0ba3c5eee43f69e977b6e
--
2.26.2