summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-05-21 20:18:53 +0200
committerSefa Eyeoglu2020-05-21 20:18:53 +0200
commit34277358056292b20b34263e030fc7b24959d815 (patch)
treec3e9c5f13bfce900c27dfdc9b552dd4103236038
parent1ec4d1ed397caa1d5699721be1f7b4658306c955 (diff)
downloadaur-34277358056292b20b34263e030fc7b24959d815.tar.gz
upgpkg: gamescope-git 3.6.1.r23.g5ab3129-2
Use system libliftoff, too
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
-rw-r--r--use-system-libs.patch (renamed from use-system-wlroots.patch)31
3 files changed, 40 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a078e3ce099e..88297751729c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gamescope-git
pkgdesc = Micro-compositor formerly known as steamcompmgr
pkgver = 3.6.1.r23.g5ab3129
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Plagman/gamescope
arch = x86_64
license = custom:BSD-2-Clause
@@ -14,18 +14,15 @@ pkgbase = gamescope-git
depends = libxcomposite
depends = vulkan-icd-loader
depends = libxtst
+ depends = libliftoff
provides = gamescope
provides = steamcompmgr
- provides = libliftoff
conflicts = gamescope
conflicts = steamcompmgr
- conflicts = libliftoff
source = git+https://github.com/Plagman/gamescope.git
- source = git+https://github.com/emersion/libliftoff.git#commit=cfeee41ec1aa03578bfbe4cd513a25e84c407dec
- source = use-system-wlroots.patch
+ source = use-system-libs.patch
sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = 11878aae7f7c0f7ef01f0b85ce83d5fcea2b339d309dc34dea55d7bcd04ea9d03257f23313c464296b46e1e61e14b91d007c7cfb0d993434afab07f280d9961c
+ sha512sums = 2459cca2891c2de061a35dbb8896ac16c51e86e338d042e7a40f8742b59325d412232b653c6a36347af528cde8226e250f315a5b6c98d0b76ac5001099c7a245
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index 252961561571..2c33d4a2dd85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,19 @@
_pkgname=gamescope
pkgname=${_pkgname}-git
pkgver=3.6.1.r23.g5ab3129
-pkgrel=1
+pkgrel=2
pkgdesc="Micro-compositor formerly known as steamcompmgr"
arch=(x86_64)
url="https://github.com/Plagman/gamescope"
license=("custom:BSD-2-Clause")
-depends=("wlroots-git" "sdl2" "libxcomposite" "vulkan-icd-loader" "libxtst")
+depends=("wlroots-git" "sdl2" "libxcomposite" "vulkan-icd-loader" "libxtst" "libliftoff")
makedepends=("git" "meson" "ninja" "patch")
-provides=($_pkgname "steamcompmgr" "libliftoff")
-conflicts=($_pkgname "steamcompmgr" "libliftoff")
+provides=($_pkgname "steamcompmgr")
+conflicts=($_pkgname "steamcompmgr")
source=("git+https://github.com/Plagman/gamescope.git"
- "git+https://github.com/emersion/libliftoff.git#commit=cfeee41ec1aa03578bfbe4cd513a25e84c407dec"
- "use-system-wlroots.patch")
+ "use-system-libs.patch")
sha512sums=('SKIP'
- 'SKIP'
- '11878aae7f7c0f7ef01f0b85ce83d5fcea2b339d309dc34dea55d7bcd04ea9d03257f23313c464296b46e1e61e14b91d007c7cfb0d993434afab07f280d9961c')
+ '2459cca2891c2de061a35dbb8896ac16c51e86e338d042e7a40f8742b59325d412232b653c6a36347af528cde8226e250f315a5b6c98d0b76ac5001099c7a245')
pkgver() {
@@ -29,20 +27,22 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- patch -p1 < "../use-system-wlroots.patch"
- git rm "subprojects/wlroots" # remove wlroots submodule, to avoid downloading unneccessary dependencies
- git submodule init
- git config submodule.subprojects/libliftoff.url $srcdir/libliftoff
-
- git submodule update
+ patch -p1 < "../use-system-libs.patch"
}
build() {
+
meson --prefix /usr --buildtype=release "$srcdir/$_pkgname" build
ninja -C build
}
+check() {
+
+ ninja -C build test
+}
+
package() {
+
DESTDIR="$pkgdir" ninja -C build install
cd "$srcdir/$_pkgname"
diff --git a/use-system-wlroots.patch b/use-system-libs.patch
index 0ce92bf8bed2..c6fa98220e4d 100644
--- a/use-system-wlroots.patch
+++ b/use-system-libs.patch
@@ -1,36 +1,49 @@
-From 47b37ccab5e596b70a433edcd72aa528b08a3f64 Mon Sep 17 00:00:00 2001
+From 693ee2043822c0d3b724932bc17216032682c293 Mon Sep 17 00:00:00 2001
From: Sefa Eyeoglu <contact@scrumplex.net>
-Date: Thu, 21 May 2020 19:30:26 +0200
-Subject: [PATCH] packaging/archlinux: use system wlroots
+Date: Thu, 21 May 2020 20:12:37 +0200
+Subject: [PATCH] packaging/archlinux: use system libliftoff and wlroots
---
- meson.build | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
+ meson.build | 12 ++++--------
+ 1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/meson.build b/meson.build
-index 7d2fd7d..a275d50 100644
+index 7d2fd7d..fd5544a 100644
--- a/meson.build
+++ b/meson.build
-@@ -44,9 +44,7 @@ math = cc.find_library('m')
+@@ -44,9 +44,8 @@ math = cc.find_library('m')
thread_dep = dependency('threads')
sdl_dep = dependency('SDL2')
-wlroots_proj = subproject('wlroots', default_options:
- ['default_library=static', 'examples=false'])
-wlroots_static_dep = wlroots_proj.get_variable('wlroots')
++liftoff = dependency('liftoff')
+wlroots = dependency('wlroots')
shadercompiler = find_program('glslangValidator')
-@@ -76,7 +74,7 @@ executable(
+@@ -60,9 +59,6 @@ spirv_shader = custom_target('shader_target',
+ install : false,
+ )
+
+-liftoff_proj = subproject('libliftoff', default_options:
+- ['default_library=static'])
+-libftoff_dep = liftoff_proj.get_variable('liftoff')
+
+ executable(
+ 'gamescope',
+@@ -76,8 +72,8 @@ executable(
dependencies : [
dep_x11, dep_xdamage, dep_xcomposite, dep_xrender, dep_xext,
dep_xxf86vm, pixman_dep, drm_dep, wayland_server, wayland_protos,
- libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots_static_dep,
+- vulkan_dep, libftoff_dep, dep_xtst
+ libinput, xkbcommon, math, thread_dep, sdl_dep, wlroots,
- vulkan_dep, libftoff_dep, dep_xtst
++ vulkan_dep, liftoff, dep_xtst
],
install: true,
+ )
--
2.26.2